CVE-2026-32273 Discourse: XSS on category description update via API

Medium 5.4 Published Updated

Attackers can inject malicious scripts into category descriptions via the API, potentially compromising user sessions and data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-32273?

CVE-2026-32273 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 31 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, updating a category description via API is not sanitizing the description string, which can lead to XSS attacks. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-32273?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.3, 2026.2.2

Products include Discourse Discourse.

How do I fix CVE-2026-32273?

Upgrade discourse to a fixed version for your release line: 2026.1.3 or 2026.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-32273 being exploited?

There is no known exploitation of CVE-2026-32273 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-32273, GHSA-h2h4-767x-6pc8.

Is CVE-2026-32273 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free