CVE-2026-32276 Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin

High 8.8 Published Updated

An authenticated user can execute arbitrary code in the Connect-CMS Code Study Plugin, requiring a patch to mitigate.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32276?

CVE-2026-32276 is a high-severity code injection vulnerability in opensource-workshop connect-cms, published on 23 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, an authenticated user may be able to execute arbitrary code in the Code Study Plugin. Versions 1.41.1 and 2.41.1 contain a patch.

Weakness: CWE-94

Which versions are affected by CVE-2026-32276?

4 open source packages ship an affected version, including opensource-workshop/connect-cms. It affects 1 product.

PackageAffectedFixed in
opensource-workshop/connect-cms PackagistAll versions1.41.1
opensource-workshop/connect-cms PackagistAll versions1.41.1
opensource-workshop/connect-cms PackagistFrom 2.0.02.41.1
opensource-workshop/connect-cms PackagistFrom 2.0.02.41.1

Products include Opensource-Workshop Connect-Cms.

How do I fix CVE-2026-32276?

Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.41.1 or 2.41.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-32276 being exploited?

There is no known exploitation of CVE-2026-32276 in the wild and no public exploit code.

Sources

Also known as GHSA-hxqw-6qv7-cqfv.

Is CVE-2026-32276 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free