{"answers":{"affected":"4 open source packages ship an affected version, including opensource-workshop/connect-cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-32276 in the wild and no public exploit code.","fix":"Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.41.1 or 2.41.1.","what":"CVE-2026-32276 is a high-severity code injection vulnerability in opensource-workshop connect-cms, published on 23 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32276 and fix it if it is affected.\n\nWhat it is: CVE-2026-32276 is a high-severity code injection vulnerability in opensource-workshop connect-cms, published on 23 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-32276 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.41.1\n- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.41.1\n- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.41.1\n- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.41.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32276/ (Markdown: https://insights.sbomify.com/CVE-2026-32276/index.md)","id":"CVE-2026-32276","markdown":"https://insights.sbomify.com/CVE-2026-32276/index.md","name":"CVE-2026-32276","record":{"aliases":["GHSA-hxqw-6qv7-cqfv"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Connect-CMS plugin","requires_auth":"low_privilege","summary":"An authenticated user can execute arbitrary code in the Connect-CMS Code Study Plugin, requiring a patch to mitigate.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"connect-cms","vendor":"opensource-workshop"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, an authenticated user may be able to execute arbitrary code in the Code Study Plugin. Versions 1.41.1 and 2.41.1 contain a patch.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin","id":"CVE-2026-32276","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View","id":"CVE-2026-32277"},"packages":[{"ecosystem":"Packagist","fixed":["1.41.1"],"introduced":["0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":null,"source":"GHSA-hxqw-6qv7-cqfv"},{"ecosystem":"Packagist","fixed":["1.41.1"],"introduced":["0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":"pkg:composer/opensource-workshop/connect-cms","source":"GHSA-hxqw-6qv7-cqfv"},{"ecosystem":"Packagist","fixed":["2.41.1"],"introduced":["2.0.0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":null,"source":"GHSA-hxqw-6qv7-cqfv"},{"ecosystem":"Packagist","fixed":["2.41.1"],"introduced":["2.0.0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":"pkg:composer/opensource-workshop/connect-cms","source":"GHSA-hxqw-6qv7-cqfv"}],"prev":{"headline":"Tautulli: Unsanitized JSONP callback parameter allows cross-origin script injection and API key theft","id":"CVE-2026-32275"},"products":["connect-cms"],"published":"2026-03-23","related":[{"cvss_score":8.7,"headline":"Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View","id":"CVE-2026-32277","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":8.2,"headline":"Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin","id":"CVE-2026-32278","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":8.1,"headline":"Connect CMS: Improper Authorization in the My Page Profile Update Feature Allows Modification of Arbitrary User Information","id":"CVE-2026-32300","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Connect CMS: Information Disclosure Due to Improper Authorization through the Page Content Retrieval Feature","id":"CVE-2026-32299","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":6.8,"headline":"Connect CMS has SSRF in the External Page Migration Feature of its Page Management Plugin","id":"CVE-2026-32279","kev_date_added":null,"published":"2026-03-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-24","vendors":["opensource-workshop"]},"summary":"An authenticated user can execute arbitrary code in the Connect-CMS Code Study Plugin, requiring a patch to mitigate.","url":"https://insights.sbomify.com/CVE-2026-32276/"}