# CVE-2026-32276: Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin

> An authenticated user can execute arbitrary code in the Connect-CMS Code Study Plugin, requiring a patch to mitigate.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-hxqw-6qv7-cqfv

## What is CVE-2026-32276?

CVE-2026-32276 is a high-severity code injection vulnerability in opensource-workshop connect-cms, published on 23 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, an authenticated user may be able to execute arbitrary code in the Code Study Plugin. Versions 1.41.1 and 2.41.1 contain a patch.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-32276?

4 open source packages ship an affected version, including opensource-workshop/connect-cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opensource-workshop/connect-cms` | Packagist | All versions | 1.41.1 |
| `opensource-workshop/connect-cms` | Packagist | All versions | 1.41.1 |
| `opensource-workshop/connect-cms` | Packagist | From 2.0.0 | 2.41.1 |
| `opensource-workshop/connect-cms` | Packagist | From 2.0.0 | 2.41.1 |

Products: Opensource-Workshop Connect-Cms.

## How do I fix CVE-2026-32276?

Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.41.1 or 2.41.1.

## Is CVE-2026-32276 being exploited?

There is no known exploitation of CVE-2026-32276 in the wild and no public exploit code.

## Other vulnerabilities in opensource-workshop connect-cms

- [CVE-2026-32277](https://insights.sbomify.com/CVE-2026-32277/): Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View (high 8.7)
- [CVE-2026-32278](https://insights.sbomify.com/CVE-2026-32278/): Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin (high 8.2)
- [CVE-2026-32300](https://insights.sbomify.com/CVE-2026-32300/): Connect CMS: Improper Authorization in the My Page Profile Update Feature Allows Modification of Arbitrary User Information (high 8.1)
- [CVE-2026-32299](https://insights.sbomify.com/CVE-2026-32299/): Connect CMS: Information Disclosure Due to Improper Authorization through the Page Content Retrieval Feature (high 7.5)
- [CVE-2026-32279](https://insights.sbomify.com/CVE-2026-32279/): Connect CMS has SSRF in the External Page Migration Feature of its Page Management Plugin (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32276 and fix it if it is affected.

What it is: CVE-2026-32276 is a high-severity code injection vulnerability in opensource-workshop connect-cms, published on 23 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32276 in the wild and no public exploit code.

Affected packages and fixed versions:
- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.41.1
- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.41.1
- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.41.1
- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.41.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32276/ (Markdown: https://insights.sbomify.com/CVE-2026-32276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32276
- OSV: https://osv.dev/vulnerability/CVE-2026-32276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32276/
Summaries are generated and may contain mistakes; the official description above is the record.
