{"answers":{"affected":"4 open source packages ship an affected version, including opensource-workshop/connect-cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-32277 in the wild and no public exploit code.","fix":"Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.41.1 or 2.41.1.","what":"CVE-2026-32277 is a high-severity cross-site scripting vulnerability in opensource-workshop connect-cms, published on 23 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-32277 and fix it if it is affected.\n\nWhat it is: CVE-2026-32277 is a high-severity cross-site scripting vulnerability in opensource-workshop connect-cms, published on 23 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-32277 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opensource-workshop/connect-cms (Packagist): affected from 1.35.0; fixed in 1.41.1\n- opensource-workshop/connect-cms (Packagist): affected from 1.35.0; fixed in 1.41.1\n- opensource-workshop/connect-cms (Packagist): affected from 2.35.0; fixed in 2.41.1\n- opensource-workshop/connect-cms (Packagist): affected from 2.35.0; fixed in 2.41.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32277/ (Markdown: https://insights.sbomify.com/CVE-2026-32277/index.md)","id":"CVE-2026-32277","markdown":"https://insights.sbomify.com/CVE-2026-32277/index.md","name":"CVE-2026-32277","record":{"aliases":["GHSA-cmfh-mpmf-fmq4"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Connect-CMS","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts in the Cabinet Plugin list view of Connect-CMS, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"connect-cms","vendor":"opensource-workshop"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Connect-CMS is a content management system. In versions 1.35.0 through 1.41.0 and 2.35.0 through 2.41.0, a DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view. Versions 1.41.1 and 2.41.1 contain a patch.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View","id":"CVE-2026-32277","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin","id":"CVE-2026-32278"},"packages":[{"ecosystem":"Packagist","fixed":["1.41.1"],"introduced":["1.35.0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":null,"source":"GHSA-cmfh-mpmf-fmq4"},{"ecosystem":"Packagist","fixed":["1.41.1"],"introduced":["1.35.0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":"pkg:composer/opensource-workshop/connect-cms","source":"GHSA-cmfh-mpmf-fmq4"},{"ecosystem":"Packagist","fixed":["2.41.1"],"introduced":["2.35.0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":null,"source":"GHSA-cmfh-mpmf-fmq4"},{"ecosystem":"Packagist","fixed":["2.41.1"],"introduced":["2.35.0"],"last_affected":[],"package":"opensource-workshop/connect-cms","purl":"pkg:composer/opensource-workshop/connect-cms","source":"GHSA-cmfh-mpmf-fmq4"}],"prev":{"headline":"Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin","id":"CVE-2026-32276"},"products":["connect-cms"],"published":"2026-03-23","related":[{"cvss_score":8.8,"headline":"Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin","id":"CVE-2026-32276","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":8.2,"headline":"Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin","id":"CVE-2026-32278","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":8.1,"headline":"Connect CMS: Improper Authorization in the My Page Profile Update Feature Allows Modification of Arbitrary User Information","id":"CVE-2026-32300","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Connect CMS: Information Disclosure Due to Improper Authorization through the Page Content Retrieval Feature","id":"CVE-2026-32299","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":6.8,"headline":"Connect CMS has SSRF in the External Page Migration Feature of its Page Management Plugin","id":"CVE-2026-32279","kev_date_added":null,"published":"2026-03-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-24","vendors":["opensource-workshop"]},"summary":"Attackers can execute arbitrary scripts in the Cabinet Plugin list view of Connect-CMS, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2026-32277/"}