CVE-2026-32279 Connect CMS has SSRF in the External Page Migration Feature of its Page Management Plugin
An attacker can exploit a Server-Side Request Forgery vulnerability in the Connect CMS Page Management Plugin to access internal resources.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32279?
CVE-2026-32279 is a medium-severity server-side request forgery vulnerability in opensource-workshop connect-cms, published on 23 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Server-Side Request Forgery (SSRF) issue exists in the external page migration feature of the Page Management Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
Weakness: CWE-918
Which versions are affected by CVE-2026-32279?
4 open source packages ship an affected version, including opensource-workshop/connect-cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
opensource-workshop/connect-cms Packagist | All versions | 1.41.1 |
opensource-workshop/connect-cms Packagist | All versions | 1.41.1 |
opensource-workshop/connect-cms Packagist | From 2.0.0 | 2.41.1 |
opensource-workshop/connect-cms Packagist | From 2.0.0 | 2.41.1 |
Products include Opensource-Workshop Connect-Cms.
How do I fix CVE-2026-32279?
Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.41.1 or 2.41.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-32279 being exploited?
There is no known exploitation of CVE-2026-32279 in the wild and no public exploit code.
Other vulnerabilities in opensource-workshop connect-cms
- CVE-2026-32276 Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin
- CVE-2026-32277 Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View
- CVE-2026-32278 Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin
- CVE-2026-32300 Connect CMS: Improper Authorization in the My Page Profile Update Feature Allows Modification of Arbitrary User Information
- CVE-2026-32299 Connect CMS: Information Disclosure Due to Improper Authorization through the Page Content Retrieval Feature
Sources
Also known as GHSA-jh46-85jr-6ph9.