# CVE-2026-32279: Connect CMS has SSRF in the External Page Migration Feature of its Page Management Plugin

> An attacker can exploit a Server-Side Request Forgery vulnerability in the Connect CMS Page Management Plugin to access internal resources.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-jh46-85jr-6ph9

## What is CVE-2026-32279?

CVE-2026-32279 is a medium-severity server-side request forgery vulnerability in opensource-workshop connect-cms, published on 23 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Server-Side Request Forgery (SSRF) issue exists in the external page migration feature of the Page Management Plugin. Versions 1.41.1 and 2.41.1 contain a patch.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-32279?

4 open source packages ship an affected version, including opensource-workshop/connect-cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opensource-workshop/connect-cms` | Packagist | All versions | 1.41.1 |
| `opensource-workshop/connect-cms` | Packagist | All versions | 1.41.1 |
| `opensource-workshop/connect-cms` | Packagist | From 2.0.0 | 2.41.1 |
| `opensource-workshop/connect-cms` | Packagist | From 2.0.0 | 2.41.1 |

Products: Opensource-Workshop Connect-Cms.

## How do I fix CVE-2026-32279?

Upgrade opensource-workshop/connect-cms to a fixed version for your release line: 1.41.1 or 2.41.1.

## Is CVE-2026-32279 being exploited?

There is no known exploitation of CVE-2026-32279 in the wild and no public exploit code.

## Other vulnerabilities in opensource-workshop connect-cms

- [CVE-2026-32276](https://insights.sbomify.com/CVE-2026-32276/): Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin (high 8.8)
- [CVE-2026-32277](https://insights.sbomify.com/CVE-2026-32277/): Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View (high 8.7)
- [CVE-2026-32278](https://insights.sbomify.com/CVE-2026-32278/): Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin (high 8.2)
- [CVE-2026-32300](https://insights.sbomify.com/CVE-2026-32300/): Connect CMS: Improper Authorization in the My Page Profile Update Feature Allows Modification of Arbitrary User Information (high 8.1)
- [CVE-2026-32299](https://insights.sbomify.com/CVE-2026-32299/): Connect CMS: Information Disclosure Due to Improper Authorization through the Page Content Retrieval Feature (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32279 and fix it if it is affected.

What it is: CVE-2026-32279 is a medium-severity server-side request forgery vulnerability in opensource-workshop connect-cms, published on 23 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32279 in the wild and no public exploit code.

Affected packages and fixed versions:
- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.41.1
- opensource-workshop/connect-cms (Packagist): affected all versions; fixed in 1.41.1
- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.41.1
- opensource-workshop/connect-cms (Packagist): affected from 2.0.0; fixed in 2.41.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32279/ (Markdown: https://insights.sbomify.com/CVE-2026-32279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32279
- OSV: https://osv.dev/vulnerability/CVE-2026-32279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32279/
Summaries are generated and may contain mistakes; the official description above is the record.
