{"answers":{"affected":"3 open source packages ship an affected version, including github.com/jackc/pgproto3/v2. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32286 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-32286 is a high-severity denial of service vulnerability in github.com/jackc/pgproto3/v2, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32286 and fix it if it is affected.\n\nWhat it is: CVE-2026-32286 is a high-severity denial of service vulnerability in github.com/jackc/pgproto3/v2, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32286 exists.\n\nAffected packages and fixed versions:\n- github.com/jackc/pgproto3/v2 (Go): affected from 2.0.0; no fix listed\n- github.com/jackc/pgproto3/v2 (Go): affected from 2.0.0 up to 2.3.3; no fix listed\n- github.com/jackc/pgproto3/v2 (Go): affected from 2.0.0 up to 2.3.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32286/ (Markdown: https://insights.sbomify.com/CVE-2026-32286/index.md)","id":"CVE-2026-32286","markdown":"https://insights.sbomify.com/CVE-2026-32286/index.md","name":"CVE-2026-32286","record":{"aliases":["CLEANSTART-2026-LY29111","CLEANSTART-2026-PO98584","CVE-2026-4427","DEBIAN-CVE-2026-32286","GHSA-jqcq-xjh3-6g23","GO-2026-4518","MINI-2pm7-6c29-7xvq","MINI-2prj-qvxh-pmc6","MINI-35m7-jc6c-j4c8","MINI-422m-rmqr-xc5m","MINI-443f-qw43-386c","MINI-62cj-85fp-48r2","MINI-66vf-59rm-rpq7","MINI-6fwx-9pvh-73j3","MINI-6gc3-wph8-j2xh","MINI-77c4-8ghx-vg9j","MINI-7mg6-6qfp-fphx","MINI-9637-mp6c-88ww","MINI-9vmx-6rx2-8j66","MINI-c254-p7wx-5j7j","MINI-c363-hphw-q6hx","MINI-f42r-6v96-6hwr","MINI-fqx4-rwgx-q5mc","MINI-ghqf-h4wf-358p","MINI-ghvx-wm83-8234","MINI-j66v-xm6m-f7gm","MINI-mm87-4xv9-52f4","MINI-pxgr-qjfw-23xq","MINI-qh8h-rmmr-jg28","MINI-v9w2-x6q6-f2r6","MINI-vfvr-2fr8-gpxw","MINI-w4w5-p9gr-wfpp","MINI-wq3x-6jx7-xcrq","MINI-wvfw-m24w-vp93","MINI-wvvr-xcw4-gqrv","MINI-wxxr-3w2j-mf3g","ROOT-APP-GOBINARY-CVE-2026-32286","UBUNTU-CVE-2026-32286"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go PostgreSQL protocol library","requires_auth":"none","summary":"A malicious PostgreSQL server can cause a client application panic by sending a DataRow message with a negative field length.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Go","cpe":[{"product":"pgproto3","vendor":"jackc"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-129","name":"Improper Validation of Array Index"},{"id":"CWE-1285","name":"Improper Validation of Specified Index, Position, or Offset in Input"}],"description":"The DataRow.Decode function fails to properly validate field lengths. A malicious or compromised PostgreSQL server can send a DataRow message with a negative field length, causing a slice bounds out of range panic.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":"2026-04-15","github_poc":2,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-04-15T19:44:25Z","kind":"github_poc","ref":"https://github.com/moisei-dev/go-dbmigrate","stars":0,"title":"Fork of jfrog/go-dbmigrate with pgx/v5 upgrade (CVE-2026-32286)"},{"date":"2026-07-31T11:50:10Z","kind":"github_poc","ref":"https://github.com/slashid/baton-retool","stars":0,"title":"SlashID fork of conductorone/baton-retool — pgx/v5 port (CVE-2026-32286, CVE-2026-41889); retire when upstream ships pgx/v5"}],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in github.com/jackc/pgproto3/v2","id":"CVE-2026-32286","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Infinite loop in github.com/antchfx/xpath","id":"CVE-2026-32287"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["2.0.0"],"last_affected":[],"package":"github.com/jackc/pgproto3/v2","purl":"pkg:golang/github.com/jackc/pgproto3/v2","source":"GO-2026-4518"},{"ecosystem":"Go","fixed":[],"introduced":["2.0.0"],"last_affected":["2.3.3"],"package":"github.com/jackc/pgproto3/v2","purl":null,"source":"GHSA-jqcq-xjh3-6g23"},{"ecosystem":"Go","fixed":[],"introduced":["2.0.0"],"last_affected":["2.3.3"],"package":"github.com/jackc/pgproto3/v2","purl":"pkg:golang/github.com/jackc/pgproto3/v2","source":"GHSA-jqcq-xjh3-6g23"}],"prev":{"headline":"Denial of service in github.com/buger/jsonparser","id":"CVE-2026-32285"},"products":["github.com/jackc/pgproto3/v2"],"published":"2026-03-26","related":[{"cvss_score":9.8,"headline":"pgx SQL Injection via Protocol Message Size Overflow","id":"CVE-2024-27304","kev_date_added":null,"published":"2024-03-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-10","vendors":["github.com/jackc/pgproto3/v2"]},"summary":"A malicious PostgreSQL server can cause a client application panic by sending a DataRow message with a negative field length.","url":"https://insights.sbomify.com/CVE-2026-32286/"}