{"answers":{"affected":"2 open source packages ship an affected version, including robrichards/xmlseclibs. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32313 exists.","fix":"Upgrade robrichards/xmlseclibs to 3.1.5 or later.","what":"CVE-2026-32313 is a high-severity vulnerability in robrichards xmlseclibs, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32313 and fix it if it is affected.\n\nWhat it is: CVE-2026-32313 is a high-severity vulnerability in robrichards xmlseclibs, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32313 exists.\n\nAffected packages and fixed versions:\n- robrichards/xmlseclibs (Packagist): affected all versions; fixed in 3.1.5\n- robrichards/xmlseclibs (Packagist): affected all versions; fixed in 3.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32313/ (Markdown: https://insights.sbomify.com/CVE-2026-32313/index.md)","id":"CVE-2026-32313","markdown":"https://insights.sbomify.com/CVE-2026-32313/index.md","name":"CVE-2026-32313","record":{"aliases":["GHSA-4v26-v6cg-g6f9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP XML security library","requires_auth":"none","summary":"Attackers can decrypt encrypted XML nodes or forge ciphertexts due to missing authentication tag validation in xmlseclibs.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"xmlseclibs","vendor":"xmlseclibs_project"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-354","name":"Improper Validation of Integrity Check Value"}],"description":"xmlseclibs is a library written in PHP for working with XML Encryption and Signatures. Prior to 3.1.5, XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. This vulnerability is fixed in 3.1.5.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"xmlseclibs is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption","id":"CVE-2026-32313","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Yamux remote Panic via malformed Data frame with SYN set and len = 262145","id":"CVE-2026-32314"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.5"],"introduced":["0"],"last_affected":[],"package":"robrichards/xmlseclibs","purl":null,"source":"GHSA-4v26-v6cg-g6f9"},{"ecosystem":"Packagist","fixed":["3.1.5"],"introduced":["0"],"last_affected":[],"package":"robrichards/xmlseclibs","purl":"pkg:composer/robrichards/xmlseclibs","source":"GHSA-4v26-v6cg-g6f9"}],"prev":{"headline":"GLPI: Unauthorized export of form structure","id":"CVE-2026-32312"},"products":["xmlseclibs"],"published":"2026-03-13","related":[{"cvss_score":6,"headline":"robrichards/xmlseclibs has an Libxml2 Canonicalization error which can bypass Digest/Signature validation","id":"CVE-2025-66578","kev_date_added":null,"published":"2025-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-16","vendors":["robrichards"]},"summary":"Attackers can decrypt encrypted XML nodes or forge ciphertexts due to missing authentication tag validation in xmlseclibs.","url":"https://insights.sbomify.com/CVE-2026-32313/"}