{"answers":{"affected":"2 open source packages ship an affected version, including yamux. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-32314 in the wild and no public exploit code.","fix":"Upgrade yamux to 0.13.10 or later.","what":"CVE-2026-32314 is a high-severity denial of service vulnerability in libp2p rust-yamux, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32314 and fix it if it is affected.\n\nWhat it is: CVE-2026-32314 is a high-severity denial of service vulnerability in libp2p rust-yamux, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-32314 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yamux (crates.io): affected all versions; fixed in 0.13.10\n- yamux (crates.io): affected all versions; fixed in 0.13.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32314/ (Markdown: https://insights.sbomify.com/CVE-2026-32314/index.md)","id":"CVE-2026-32314","markdown":"https://insights.sbomify.com/CVE-2026-32314/index.md","name":"CVE-2026-32314","record":{"aliases":["DEBIAN-CVE-2026-32314","GHSA-vxx9-2994-q338","UBUNTU-CVE-2026-32314"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust Yamux library","requires_auth":"none","summary":"Remote attackers can crash the application by sending a malformed Yamux data frame, requiring an upgrade to the Rust library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yamux","vendor":"protocol"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"Yamux is a stream multiplexer over reliable, ordered connections such as TCP/IP. Prior to 0.13.10, the Rust implementation of Yamux can panic when processing a crafted inbound Data frame that sets SYN and uses a body length greater than DEFAULT_CREDIT (e.g. 262145). On the first packet of a new inbound stream, stream state is created and a receiver is queued before oversized-body validation completes. When validation fails, the temporary stream is dropped and cleanup may call remove(...).expect(\"stream not found\"), triggering a panic in the connection state machine. This is remotely reachable over a normal Yamux session and does not require authentication. This vulnerability is fixed in 0.13.10.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Yamux remote Panic via malformed Data frame with SYN set and len = 262145","id":"CVE-2026-32314","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"motionEye: World-Readable Configuration File Exposes Admin Password Hash","id":"CVE-2026-32315"},"packages":[{"ecosystem":"crates.io","fixed":["0.13.10"],"introduced":["0"],"last_affected":[],"package":"yamux","purl":null,"source":"GHSA-vxx9-2994-q338"},{"ecosystem":"crates.io","fixed":["0.13.10"],"introduced":["0"],"last_affected":[],"package":"yamux","purl":"pkg:cargo/yamux","source":"GHSA-vxx9-2994-q338"}],"prev":{"headline":"xmlseclibs is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption","id":"CVE-2026-32313"},"products":["rust-yamux"],"published":"2026-03-13","related":[{"cvss_score":8.7,"headline":"Yamux remote Panic via malformed WindowUpdate credit","id":"CVE-2026-31814","kev_date_added":null,"published":"2026-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-16","vendors":["libp2p"]},"summary":"Remote attackers can crash the application by sending a malformed Yamux data frame, requiring an upgrade to the Rust library.","url":"https://insights.sbomify.com/CVE-2026-32314/"}