# CVE-2026-32314: Yamux remote Panic via malformed Data frame with SYN set and len = 262145

> Remote attackers can crash the application by sending a malformed Yamux data frame, requiring an upgrade to the Rust library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-32314, GHSA-vxx9-2994-q338, UBUNTU-CVE-2026-32314

## What is CVE-2026-32314?

CVE-2026-32314 is a high-severity denial of service vulnerability in libp2p rust-yamux, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yamux is a stream multiplexer over reliable, ordered connections such as TCP/IP. Prior to 0.13.10, the Rust implementation of Yamux can panic when processing a crafted inbound Data frame that sets SYN and uses a body length greater than DEFAULT_CREDIT (e.g. 262145). On the first packet of a new inbound stream, stream state is created and a receiver is queued before oversized-body validation completes. When validation fails, the temporary stream is dropped and cleanup may call remove(...).expect("stream not found"), triggering a panic in the connection state machine. This is remotely reachable over a normal Yamux session and does not require authentication. This vulnerability is fixed in 0.13.10.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-32314?

2 open source packages ship an affected version, including yamux. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yamux` | crates.io | All versions | 0.13.10 |
| `yamux` | crates.io | All versions | 0.13.10 |

Products: Protocol Yamux.

## How do I fix CVE-2026-32314?

Upgrade yamux to 0.13.10 or later.

## Is CVE-2026-32314 being exploited?

There is no known exploitation of CVE-2026-32314 in the wild and no public exploit code.

## Other vulnerabilities in libp2p rust-yamux

- [CVE-2026-31814](https://insights.sbomify.com/CVE-2026-31814/): Yamux remote Panic via malformed WindowUpdate credit (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32314 and fix it if it is affected.

What it is: CVE-2026-32314 is a high-severity denial of service vulnerability in libp2p rust-yamux, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32314 in the wild and no public exploit code.

Affected packages and fixed versions:
- yamux (crates.io): affected all versions; fixed in 0.13.10
- yamux (crates.io): affected all versions; fixed in 0.13.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32314/ (Markdown: https://insights.sbomify.com/CVE-2026-32314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32314
- OSV: https://osv.dev/vulnerability/CVE-2026-32314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32314/
Summaries are generated and may contain mistakes; the official description above is the record.
