# CVE-2026-32315: motionEye: World-Readable Configuration File Exposes Admin Password Hash

> Local attackers can read world-readable configuration files to obtain admin password hashes, enabling offline cracking and subsequent privilege escalation.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-rhgp-6wq6-9j67, PYSEC-2026-2666

## What is CVE-2026-32315?

CVE-2026-32315 is a medium-severity vulnerability in motioneye-project motioneye, published on 24 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

motionEye (mEye) is an online interface for motion software, a video surveillance program with motion detection. Versions prior to 0.44.0 create the configuration file /etc/motioneye/motion.conf with 644 permissions (-rw-r--r--), making it readable by any local user on the system. This file contains sensitive data including the admin password hash, which can be leveraged by other vulnerabilities to escalate privileges. Additionally, per-camera configuration files (camera-*.conf) are also created with the same 644 permissions, potentially exposing camera-specific credentials and settings. The exposed SHA1 admin password hash can be cracked offline to recover the plaintext password, used directly to forge authenticated admin API requests via the signature authentication weakness (GHSA-45h7-499j-7ww3), and chained with the OS command injection flaw (CVE-2025-60787) to escalate a local unprivileged user to the Motion daemon user (often root), enabling full system compromise. This issue has been fixed in version 0.44.0.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-522 (Insufficiently Protected Credentials), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-32315?

3 open source packages ship an affected version, including motioneye.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `motioneye` | PyPI | All versions | 0.44.0 |
| `motioneye` | PyPI | All versions | 0.44.0 |
| `motioneye` | PyPI | All versions | 0.44.0 |

## How do I fix CVE-2026-32315?

Upgrade motioneye to 0.44.0 or later.

## Is CVE-2026-32315 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32315 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32315 and fix it if it is affected.

What it is: CVE-2026-32315 is a medium-severity vulnerability in motioneye-project motioneye, published on 24 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32315 exists.

Affected packages and fixed versions:
- motioneye (PyPI): affected all versions; fixed in 0.44.0
- motioneye (PyPI): affected all versions; fixed in 0.44.0
- motioneye (PyPI): affected all versions; fixed in 0.44.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32315/ (Markdown: https://insights.sbomify.com/CVE-2026-32315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32315
- OSV: https://osv.dev/vulnerability/CVE-2026-32315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32315/
Summaries are generated and may contain mistakes; the official description above is the record.
