# CVE-2026-32317: Cryptomator for Android: Tampered vault configuration allows MITM attack on Hub API

> Attackers can tamper with vault configuration to redirect API requests, enabling man-in-the-middle attacks and token exfiltration for Hub-backed vaults.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-876q-q3mm-fcvj

## What is CVE-2026-32317?

CVE-2026-32317 is a high-severity missing authorization vulnerability in cryptomator android, published on 20 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cryptomator for Android offers multi-platform transparent client-side encryption for files in the cloud. Prior to version 1.12.3, an integrity check vulnerability allows an attacker tamper with the vault configuration file leading to a man-in-the-middle vulnerability in Hub key loading mechanism. Before this fix, the client trusted endpoints from the vault config without host authenticity checks, which could allow token exfiltration by mixing a legitimate auth endpoint with a malicious API endpoint. Impacted are users unlocking Hub-backed vaults with affected client versions in environments where an attacker can alter the vault.cryptomator file. This issue has been patched in version 1.12.3.

Weakness: CWE-923 (Improper Restriction of Communication Channel to Intended Endpoints), CWE-451 (User Interface (UI) Misrepresentation of Critical Information), CWE-354 (Improper Validation of Integrity Check Value), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-32317?

It affects 1 product.


Products: Cryptomator Cryptomator.

## How do I fix CVE-2026-32317?

No fix has been published for CVE-2026-32317 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-32317 being exploited?

There is no known exploitation of CVE-2026-32317 in the wild and no public exploit code.

## Other vulnerabilities in cryptomator android

- [CVE-2026-32309](https://insights.sbomify.com/CVE-2026-32309/): Cryptomator: Hub unlocking accepts plaintext HTTP and unvalidated endpoint schemes (high 8.7)
- [CVE-2022-25366](https://insights.sbomify.com/CVE-2022-25366/): Code injection in n/a (high 7.8)
- [CVE-2026-32303](https://insights.sbomify.com/CVE-2026-32303/): Cryptomator: Tampered vault configuration allows MITM attack on Hub API (high 7.6)
- [CVE-2026-32318](https://insights.sbomify.com/CVE-2026-32318/): Cryptomator for IOS: Tampered vault configuration allows MITM attack on Hub API (high 7.6)
- [CVE-2023-37907](https://insights.sbomify.com/CVE-2023-37907/): Cryptomator's MSI installer allows local privilege escalation (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32317 and fix it if it is affected.

What it is: CVE-2026-32317 is a high-severity missing authorization vulnerability in cryptomator android, published on 20 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32317 in the wild and no public exploit code.

Affected product: cryptomator android. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32317/ (Markdown: https://insights.sbomify.com/CVE-2026-32317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32317
- OSV: https://osv.dev/vulnerability/CVE-2026-32317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32317/
Summaries are generated and may contain mistakes; the official description above is the record.
