CVE-2026-32322 soroban-sdk: `Fr` scalar field equality comparison bypasses modular reduction
Attackers can bypass security checks in Soroban smart contracts by exploiting incorrect equality comparisons of unreduced scalar field values.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32322?
CVE-2026-32322 is a medium-severity vulnerability in stellar rs-soroban-sdk, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
soroban-sdk is a Rust SDK for Soroban contracts. Prior to 22.0.11, 23.5.3, and 25.3.0, The Fr (scalar field) types for BN254 and BLS12-381 in soroban-sdk compared values using their raw U256 representation without first reducing modulo the field modulus r. This caused mathematically equal field elements to compare as not-equal when one or both values were unreduced (i.e., >= r). The vulnerability requires an attacker to supply crafted Fr values through contract inputs, and compare them directly without going through host-side arithmetic operations. Smart contracts that rely on Fr equality checks for security-critical logic could produce incorrect results. The impact depends on how the affected contract uses Fr equality comparisons, but can result in incorrect authorization decisions or validation bypasses in contracts that perform equality checks on user-supplied scalar values. This vulnerability is fixed in 22.0.11, 23.5.3, and 25.3.0.
Weakness: CWE-697
Which versions are affected by CVE-2026-32322?
6 open source packages ship an affected version, including soroban-sdk. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
soroban-sdk crates.io | All versions | 22.0.11 |
soroban-sdk crates.io | All versions | 22.0.11 |
soroban-sdk crates.io | From 23.0.0 | 23.5.3 |
soroban-sdk crates.io | From 23.0.0 | 23.5.3 |
soroban-sdk crates.io | From 25.0.0 | 25.3.0 |
soroban-sdk crates.io | From 25.0.0 | 25.3.0 |
Products include Stellar Rs-Soroban-Sdk.
How do I fix CVE-2026-32322?
Upgrade soroban-sdk to a fixed version for your release line: 22.0.11, 23.5.3 or 25.3.0.
Is CVE-2026-32322 being exploited?
There is no known exploitation of CVE-2026-32322 in the wild and no public exploit code.
Other vulnerabilities in stellar rs-soroban-sdk
Sources
Also known as GHSA-x2hw-px52-wp4m.