{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-32323 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-32323 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-32323 is a high-severity vulnerability in mullvadvpn-app, published on 19 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-32323 and fix it if it is affected.\n\nWhat it is: CVE-2026-32323 is a high-severity vulnerability in mullvadvpn-app, published on 19 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-32323 in the wild and no public exploit code.\n\nAffected product: mullvadvpn-app. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32323/ (Markdown: https://insights.sbomify.com/CVE-2026-32323/index.md)","id":"CVE-2026-32323","markdown":"https://insights.sbomify.com/CVE-2026-32323/index.md","name":"CVE-2026-32323","record":{"aliases":["GHSA-c2g6-w5fq-vw3m"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Mullvad VPN client","requires_auth":"low_privilege","summary":"Local attackers with admin access can escalate privileges to root by placing a malicious bundle in the application directory during installation.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mullvad_vpn","vendor":"mullvad"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-427","name":"Uncontrolled Search Path Element"},{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Mullvad VPN is a VPN client app for desktop and mobile. When using macOS with versions 2026.1 and below, Mullvad VPN may allow local privilege escalation during installation or upgrade. The installer package executes binaries from /Applications/Mullvad VPN.app without verifying if the bundle is attacker-controlled or that the path is the legitimate Mullvad application. A user in the admin group can pre-place a crafted application bundle at that location and may be able to achieve code execution as root. Since the issue only affected the installer, there is no immediate need for users to update if they are already running an older version. This issue has been fixed in version 2026.2-beta1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Mullvad VPN for macOS: Local Privilege Escalation via unverified bundle path in installer","id":"CVE-2026-32323","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Anviz CX7 Firmware Use of Hard-coded Cryptographic Key","id":"CVE-2026-32324"},"packages":[],"prev":{"headline":"soroban-sdk: `Fr` scalar field equality comparison bypasses modular reduction","id":"CVE-2026-32322"},"products":["mullvadvpn-app"],"published":"2026-05-19","related":[{"cvss_score":7.8,"headline":"Privilege escalation in n/a","id":"CVE-2023-50446","kev_date_added":null,"published":"2023-12-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-20","vendors":["mullvad"]},"summary":"Local attackers with admin access can escalate privileges to root by placing a malicious bundle in the application directory during installation.","url":"https://insights.sbomify.com/CVE-2026-32323/"}