# CVE-2026-32323: Mullvad VPN for macOS: Local Privilege Escalation via unverified bundle path in installer

> Local attackers with admin access can escalate privileges to root by placing a malicious bundle in the application directory during installation.

- **Severity:** High 7.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 May 2026
- **Updated:** 20 May 2026
- **Also known as:** GHSA-c2g6-w5fq-vw3m

## What is CVE-2026-32323?

CVE-2026-32323 is a high-severity vulnerability in mullvadvpn-app, published on 19 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Mullvad VPN is a VPN client app for desktop and mobile. When using macOS with versions 2026.1 and below, Mullvad VPN may allow local privilege escalation during installation or upgrade. The installer package executes binaries from /Applications/Mullvad VPN.app without verifying if the bundle is attacker-controlled or that the path is the legitimate Mullvad application. A user in the admin group can pre-place a crafted application bundle at that location and may be able to achieve code execution as root. Since the issue only affected the installer, there is no immediate need for users to update if they are already running an older version. This issue has been fixed in version 2026.2-beta1.

Weakness: CWE-427 (Uncontrolled Search Path Element), CWE-345 (Insufficient Verification of Data Authenticity), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-32323?

It affects 1 product.


Products: Mullvad Mullvad Vpn.

## How do I fix CVE-2026-32323?

No fix has been published for CVE-2026-32323 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-32323 being exploited?

There is no known exploitation of CVE-2026-32323 in the wild and no public exploit code.

## Other vulnerabilities in mullvadvpn-app

- [CVE-2023-50446](https://insights.sbomify.com/CVE-2023-50446/): Privilege escalation in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32323 and fix it if it is affected.

What it is: CVE-2026-32323 is a high-severity vulnerability in mullvadvpn-app, published on 19 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32323 in the wild and no public exploit code.

Affected product: mullvadvpn-app. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32323/ (Markdown: https://insights.sbomify.com/CVE-2026-32323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32323
- OSV: https://osv.dev/vulnerability/CVE-2026-32323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32323/
Summaries are generated and may contain mistakes; the official description above is the record.
