CVE-2026-32327 Apache Portable Runtime Utility: apr-util XML stack recursion crash

Critical 9.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-32327?

CVE-2026-32327 is a critical vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026.

Official description

A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function.

Users are recommended to upgrade to version 1.6.4, which fixes this issue.

Weakness: CWE-674

Which versions are affected by CVE-2026-32327?

1 open source package ship an affected version, including apr-util. It affects 1 product.

PackageAffectedFixed in
apr-util BitnamiAll versions1.6.4

Products include Apache Apr-Util.

How do I fix CVE-2026-32327?

Upgrade apr-util to 1.6.4 or later.

Is CVE-2026-32327 being exploited?

There is no known exploitation of CVE-2026-32327 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2026-32327, AZL-94514, BELL-CVE-2026-32327, BIT-apr-util-2026-32327, CLSA-2026-1792441215, DEBIAN-CVE-2026-32327 and 3 more.

Is CVE-2026-32327 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free