CVE-2026-3240 Concrete CMS below 9.4.8 is vulnerable to Stored XSS via Legacy form
An attacker with page editing permissions can inject malicious scripts into the Legacy form Question field, potentially compromising high-privilege user accounts.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-3240?
CVE-2026-3240 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 4 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
In Concrete CMS below version 9.4.8, a user with permission to edit a page with element Legacy form can perform a stored XSS attack towards high-privilege accounts via the Question field. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 4.8 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N Thanks minhnn42, namdi and quanlna2 from VCSLab-Viettel Cyber Security for reporting.
Weakness: CWE-79
Which versions are affected by CVE-2026-3240?
2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | All versions | 9.4.8 |
concrete5/concrete5 Packagist | All versions | 9.4.8 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2026-3240?
Upgrade concrete5/concrete5 to 9.4.8 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-3240 being exploited?
There is no known exploitation of CVE-2026-3240 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-45fj-fvmm-xcc5.