CVE-2026-3242 Concrete CMS below 9.4.8 is vulnerable to Stored XSS in the Switch Language block

Medium 4.8 Published Updated

A rogue administrator can inject stored XSS via the Switch Language block in Concrete CMS, allowing potential data modification.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-3242?

CVE-2026-3242 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 4 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

In Concrete CMS below version 9.4.8, a rogue administrator can add stored XSS via the Switch Language block.  The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 4.8 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N.  Thanks M3dium for reporting.

Weakness: CWE-79

Which versions are affected by CVE-2026-3242?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions9.4.8
concrete5/concrete5 PackagistAll versions9.4.8

Products include Concretecms Concrete Cms.

How do I fix CVE-2026-3242?

Upgrade concrete5/concrete5 to 9.4.8 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-3242 being exploited?

There is no known exploitation of CVE-2026-3242 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-w9qg-chfh-g3q9.

Is CVE-2026-3242 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free