CVE-2026-32600 xml-security is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption
Attackers can decrypt encrypted XML nodes and forge ciphertexts due to missing AES-GCM authentication tag validation in the xml-security library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32600?
CVE-2026-32600 is a high-severity vulnerability in simplesamlphp xml-security, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
xml-security is a library that implements XML signatures and encryption. Prior to versions 2.3.1 and 1.13.9, XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. This vulnerability is fixed in 2.3.1 and 1.13.9.
Weakness: CWE-354
Which versions are affected by CVE-2026-32600?
4 open source packages ship an affected version, including simplesamlphp/xml-security. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
simplesamlphp/xml-security Packagist | All versions | 1.13.9 |
simplesamlphp/xml-security Packagist | All versions | 1.13.9 |
simplesamlphp/xml-security Packagist | From 2.0.0 | 2.3.1 |
simplesamlphp/xml-security Packagist | From 2.0.0 | 2.3.1 |
Products include Simplesamlphp Xml-Security.
How do I fix CVE-2026-32600?
Upgrade simplesamlphp/xml-security to a fixed version for your release line: 1.13.9 or 2.3.1.
Is CVE-2026-32600 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32600 exists.
Sources
Also known as GHSA-r353-4845-pr5p.