{"answers":{"affected":"4 open source packages ship an affected version, including simplesamlphp/xml-security. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32600 exists.","fix":"Upgrade simplesamlphp/xml-security to a fixed version for your release line: 1.13.9 or 2.3.1.","what":"CVE-2026-32600 is a high-severity vulnerability in simplesamlphp xml-security, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32600 and fix it if it is affected.\n\nWhat it is: CVE-2026-32600 is a high-severity vulnerability in simplesamlphp xml-security, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32600 exists.\n\nAffected packages and fixed versions:\n- simplesamlphp/xml-security (Packagist): affected all versions; fixed in 1.13.9\n- simplesamlphp/xml-security (Packagist): affected all versions; fixed in 1.13.9\n- simplesamlphp/xml-security (Packagist): affected from 2.0.0; fixed in 2.3.1\n- simplesamlphp/xml-security (Packagist): affected from 2.0.0; fixed in 2.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32600/ (Markdown: https://insights.sbomify.com/CVE-2026-32600/index.md)","id":"CVE-2026-32600","markdown":"https://insights.sbomify.com/CVE-2026-32600/index.md","name":"CVE-2026-32600","record":{"aliases":["GHSA-r353-4845-pr5p"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"XML security library","requires_auth":"none","summary":"Attackers can decrypt encrypted XML nodes and forge ciphertexts due to missing AES-GCM authentication tag validation in the xml-security library.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"xml-security","vendor":"simplesamlphp"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-354","name":"Improper Validation of Integrity Check Value"}],"description":"xml-security is a library that implements XML signatures and encryption. Prior to versions 2.3.1 and 1.13.9, XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. This vulnerability is fixed in 2.3.1 and 1.13.9.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"xml-security is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption","id":"CVE-2026-32600","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"Homarr has a Race Condition in Invite Token Registration (TOCTOU)","id":"CVE-2026-32602"},"packages":[{"ecosystem":"Packagist","fixed":["1.13.9"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/xml-security","purl":null,"source":"GHSA-r353-4845-pr5p"},{"ecosystem":"Packagist","fixed":["1.13.9"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/xml-security","purl":"pkg:composer/simplesamlphp/xml-security","source":"GHSA-r353-4845-pr5p"},{"ecosystem":"Packagist","fixed":["2.3.1"],"introduced":["2.0.0"],"last_affected":[],"package":"simplesamlphp/xml-security","purl":null,"source":"GHSA-r353-4845-pr5p"},{"ecosystem":"Packagist","fixed":["2.3.1"],"introduced":["2.0.0"],"last_affected":[],"package":"simplesamlphp/xml-security","purl":"pkg:composer/simplesamlphp/xml-security","source":"GHSA-r353-4845-pr5p"}],"prev":{"headline":"Netmaker has a boolean‑based SQL Injection","id":"CVE-2026-32599"},"products":["xml-security"],"published":"2026-03-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-16","vendors":["simplesamlphp"]},"summary":"Attackers can decrypt encrypted XML nodes and forge ciphertexts due to missing AES-GCM authentication tag validation in the xml-security library.","url":"https://insights.sbomify.com/CVE-2026-32600/"}