# CVE-2026-32600: xml-security is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption

> Attackers can decrypt encrypted XML nodes and forge ciphertexts due to missing AES-GCM authentication tag validation in the xml-security library.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** GHSA-r353-4845-pr5p

## What is CVE-2026-32600?

CVE-2026-32600 is a high-severity vulnerability in simplesamlphp xml-security, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xml-security is a library that implements XML signatures and encryption. Prior to versions 2.3.1 and 1.13.9, XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. This vulnerability is fixed in 2.3.1 and 1.13.9.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2026-32600?

4 open source packages ship an affected version, including simplesamlphp/xml-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/xml-security` | Packagist | All versions | 1.13.9 |
| `simplesamlphp/xml-security` | Packagist | All versions | 1.13.9 |
| `simplesamlphp/xml-security` | Packagist | From 2.0.0 | 2.3.1 |
| `simplesamlphp/xml-security` | Packagist | From 2.0.0 | 2.3.1 |

Products: Simplesamlphp Xml-Security.

## How do I fix CVE-2026-32600?

Upgrade simplesamlphp/xml-security to a fixed version for your release line: 1.13.9 or 2.3.1.

## Is CVE-2026-32600 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32600 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32600 and fix it if it is affected.

What it is: CVE-2026-32600 is a high-severity vulnerability in simplesamlphp xml-security, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32600 exists.

Affected packages and fixed versions:
- simplesamlphp/xml-security (Packagist): affected all versions; fixed in 1.13.9
- simplesamlphp/xml-security (Packagist): affected all versions; fixed in 1.13.9
- simplesamlphp/xml-security (Packagist): affected from 2.0.0; fixed in 2.3.1
- simplesamlphp/xml-security (Packagist): affected from 2.0.0; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32600/ (Markdown: https://insights.sbomify.com/CVE-2026-32600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32600
- OSV: https://osv.dev/vulnerability/CVE-2026-32600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32600/
Summaries are generated and may contain mistakes; the official description above is the record.
