# CVE-2026-32604: Spinnaker: RCE when using gitrepo artifact types due to improper sanitization of user input on branch and paths

> Attackers can execute arbitrary commands on Spinnaker clouddriver pods via unsanitized gitrepo artifact inputs, exposing credentials and modifying resources.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-x3j7-7pgj-h87r

## What is CVE-2026-32604?

CVE-2026-32604 is a critical command injection vulnerability in spinnaker, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spinnaker is an open source, multi-cloud continuous delivery platform. In versions prior to 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2, a bad actor can execute arbitrary commands very simply on the clouddriver pods. This can expose credentials, remove files, or inject resources easily. Versions 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2 contain a patch. As a workaround, disable the gitrepo artifact types.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-32604?

2 open source packages ship an affected version, including io.spinnaker.clouddriver:clouddriver-artifacts-gitrepo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.spinnaker.clouddriver:clouddriver-artifacts-gitrepo` | Maven | All versions | 2026.0.1 |
| `io.spinnaker.clouddriver:clouddriver-artifacts-gitrepo` | Maven | All versions | 2026.0.1 |

Products: Linuxfoundation Spinnaker.

## How do I fix CVE-2026-32604?

Upgrade io.spinnaker.clouddriver:clouddriver-artifacts-gitrepo to 2026.0.1 or later.

## Is CVE-2026-32604 being exploited?

There is no known exploitation of CVE-2026-32604 in the wild and no public exploit code.

Public exploit code:

- POCs for CVE-2026-32604 and CVE-2026-32613 which allow post-auth RCE and credential theft in Spinnaker (github_poc): https://github.com/ZeroPathAI/spinnaker-poc

## Other vulnerabilities in spinnaker

- [CVE-2026-32613](https://insights.sbomify.com/CVE-2026-32613/): Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling (critical 10.0)
- [CVE-2021-43832](https://insights.sbomify.com/CVE-2021-43832/): Improper Access Control in spinnaker (critical 10.0)
- [CVE-2026-44795](https://insights.sbomify.com/CVE-2026-44795/): Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types (high 8.8)
- [CVE-2020-9301](https://insights.sbomify.com/CVE-2020-9301/): Code injection in Netflix Spinnaker (high 8.8)
- [CVE-2025-61916](https://insights.sbomify.com/CVE-2025-61916/): Spinnaker vulnerable to SSRF due to improper restrictions on http from user input (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32604 and fix it if it is affected.

What it is: CVE-2026-32604 is a critical command injection vulnerability in spinnaker, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32604 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.spinnaker.clouddriver:clouddriver-artifacts-gitrepo (Maven): affected all versions; fixed in 2026.0.1
- io.spinnaker.clouddriver:clouddriver-artifacts-gitrepo (Maven): affected all versions; fixed in 2026.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32604/ (Markdown: https://insights.sbomify.com/CVE-2026-32604/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32604
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32604
- OSV: https://osv.dev/vulnerability/CVE-2026-32604

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32604/
Summaries are generated and may contain mistakes; the official description above is the record.
