# CVE-2026-32607: Discourse: Stored XSS via unescaped assignee name

> Attackers with assign permissions can inject malicious scripts via unescaped names, executing code in victims' browsers when viewing topics.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 1 Apr 2026
- **Also known as:** BIT-discourse-2026-32607, GHSA-xg68-q7ff-6gqm

## What is CVE-2026-32607?

CVE-2026-32607 is a low-severity cross-site scripting vulnerability in Discourse Discourse, published on 31 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, when the hidden prioritize_full_name_in_ux site setting is enabled (defaults to false, requires console access to change), user and group display names are rendered without HTML escaping in several assignment-related UI paths. This allows users with assign permission to inject arbitrary HTML/JavaScript that executes in the browser of any user viewing an affected topic. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-32607?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | From 2026.1.0 | 2026.1.3, 2026.2.2 |

Products: Discourse Discourse.

## How do I fix CVE-2026-32607?

Upgrade discourse to a fixed version for your release line: 2026.1.3 or 2026.2.2.

## Is CVE-2026-32607 being exploited?

There is no known exploitation of CVE-2026-32607 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32607 and fix it if it is affected.

What it is: CVE-2026-32607 is a low-severity cross-site scripting vulnerability in Discourse Discourse, published on 31 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32607 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected from 2026.1.0; fixed in 2026.1.3, 2026.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32607/ (Markdown: https://insights.sbomify.com/CVE-2026-32607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32607
- OSV: https://osv.dev/vulnerability/CVE-2026-32607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32607/
Summaries are generated and may contain mistakes; the official description above is the record.
