# CVE-2026-32608: Glances has a Command Injection via Process Names in Action Command Templates

> Attackers can execute arbitrary commands by injecting metacharacters into process names within Glances action templates, requiring custom action configurations.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-32608, GHSA-vcv2-q258-wrg7, PYSEC-2026-2167, UBUNTU-CVE-2026-32608

## What is CVE-2026-32608?

CVE-2026-32608 is a high-severity command injection vulnerability in nicolargo glances, published on 18 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Glances is an open-source system cross-platform monitoring tool. The Glances action system allows administrators to configure shell commands that execute when monitoring thresholds are exceeded. These commands support Mustache template variables (e.g., `{{name}}`, `{{key}}`) that are populated with runtime monitoring data. The `secure_popen()` function, which executes these commands, implements its own pipe, redirect, and chain operator handling by splitting the command string before passing each segment to `subprocess.Popen(shell=False)`. Prior to 4.5.2, when a Mustache-rendered value (such as a process name, filesystem mount point, or container name) contains pipe, redirect, or chain metacharacters, the rendered command is split in unintended ways, allowing an attacker who controls a process name or container name to inject arbitrary commands. Version 4.5.2 fixes the issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-32608?

3 open source packages ship an affected version, including glances and Glances. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.2 |
| `glances` | PyPI | All versions | 4.5.2 |
| `Glances` | PyPI | All versions | 4.5.2 |

Products: Nicolargo Glances.

## How do I fix CVE-2026-32608?

Upgrade glances to 4.5.2 or later.

## Is CVE-2026-32608 being exploited?

There is no known exploitation of CVE-2026-32608 in the wild and no public exploit code.

## Other vulnerabilities in nicolargo glances

- [CVE-2026-32633](https://insights.sbomify.com/CVE-2026-32633/): Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist` (critical 9.1)
- [CVE-2026-32596](https://insights.sbomify.com/CVE-2026-32596/): Glances exposes the REST API without authentication (high 8.7)
- [CVE-2026-30928](https://insights.sbomify.com/CVE-2026-30928/): Glances Exposes Unauthenticated Configuration Secrets (high 8.7)
- [CVE-2026-32610](https://insights.sbomify.com/CVE-2026-32610/): Glances's Default CORS Configuration Allows Cross-Origin Credential Theft (high 8.1)
- [CVE-2026-32634](https://insights.sbomify.com/CVE-2026-32634/): Glances Central Browser Autodiscovery Leaks Reusable Credentials to Zeroconf-Spoofed Servers (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32608 and fix it if it is affected.

What it is: CVE-2026-32608 is a high-severity command injection vulnerability in nicolargo glances, published on 18 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32608 in the wild and no public exploit code.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.2
- glances (PyPI): affected all versions; fixed in 4.5.2
- Glances (PyPI): affected all versions; fixed in 4.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32608/ (Markdown: https://insights.sbomify.com/CVE-2026-32608/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32608
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32608
- OSV: https://osv.dev/vulnerability/CVE-2026-32608

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32608/
Summaries are generated and may contain mistakes; the official description above is the record.
