# CVE-2026-32611: Glances has a SQL Injection in DuckDB Export via Unparameterized DDL Statements

> Attacker can execute arbitrary SQL commands via unparameterized DDL statements in the DuckDB export module of Glances.

- **Severity:** High 7.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-32611, GHSA-49g7-2ww7-3vf5, PYSEC-2026-2170, UBUNTU-CVE-2026-32611

## What is CVE-2026-32611?

CVE-2026-32611 is a high-severity SQL injection vulnerability in nicolargo glances, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Glances is an open-source system cross-platform monitoring tool. The GHSA-x46r fix (commit 39161f0) addressed SQL injection in the TimescaleDB export module by converting all SQL operations to use parameterized queries and `psycopg.sql` composable objects. However, the DuckDB export module (`glances/exports/glances_duckdb/__init__.py`) was not included in this fix and contains the same class of vulnerability: table names and column names derived from monitoring statistics are directly interpolated into SQL statements via f-strings. While DuckDB INSERT values already use parameterized queries (`?` placeholders), the DDL construction and table name references do not escape or parameterize identifier names. Version 4.5.3 provides a more complete fix.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-32611?

3 open source packages ship an affected version, including glances and Glances. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.2 |
| `glances` | PyPI | All versions | 4.5.2 |
| `Glances` | PyPI | All versions | 4.5.2 |

Products: Nicolargo Glances.

## How do I fix CVE-2026-32611?

Upgrade glances to 4.5.2 or later.

## Is CVE-2026-32611 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32611 exists.

## Other vulnerabilities in nicolargo glances

- [CVE-2026-32633](https://insights.sbomify.com/CVE-2026-32633/): Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist` (critical 9.1)
- [CVE-2026-32596](https://insights.sbomify.com/CVE-2026-32596/): Glances exposes the REST API without authentication (high 8.7)
- [CVE-2026-30928](https://insights.sbomify.com/CVE-2026-30928/): Glances Exposes Unauthenticated Configuration Secrets (high 8.7)
- [CVE-2026-32610](https://insights.sbomify.com/CVE-2026-32610/): Glances's Default CORS Configuration Allows Cross-Origin Credential Theft (high 8.1)
- [CVE-2026-32634](https://insights.sbomify.com/CVE-2026-32634/): Glances Central Browser Autodiscovery Leaks Reusable Credentials to Zeroconf-Spoofed Servers (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32611 and fix it if it is affected.

What it is: CVE-2026-32611 is a high-severity SQL injection vulnerability in nicolargo glances, published on 18 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32611 exists.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.2
- glances (PyPI): affected all versions; fixed in 4.5.2
- Glances (PyPI): affected all versions; fixed in 4.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32611/ (Markdown: https://insights.sbomify.com/CVE-2026-32611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32611
- OSV: https://osv.dev/vulnerability/CVE-2026-32611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32611/
Summaries are generated and may contain mistakes; the official description above is the record.
