CVE-2026-32612 Statamic: privilege escalation via stored cross-site scripting

Medium 5.4 Published Updated

Authenticated users can inject malicious scripts via color preferences, leading to privilege escalation when higher-privileged users impersonate them.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-32612?

CVE-2026-32612 is a medium-severity cross-site scripting vulnerability in statamic cms, published on 12 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Statamic is a Laravel and Git powered content management system (CMS). Prior to 6.6.2, stored XSS in the control panel color mode preference allows authenticated users with control panel access to inject malicious JavaScript that executes when a higher-privileged user impersonates their account. This has been fixed in 6.6.2.

Weakness: CWE-79

Which versions are affected by CVE-2026-32612?

2 open source packages ship an affected version, including statamic/cms. It affects 1 product.

PackageAffectedFixed in
statamic/cms PackagistFrom 6.0.06.6.2
statamic/cms PackagistFrom 6.0.06.6.2

Products include Statamic Statamic.

How do I fix CVE-2026-32612?

Upgrade statamic/cms to 6.6.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-32612 being exploited?

There is no known exploitation of CVE-2026-32612 in the wild and no public exploit code.

Sources

Also known as GHSA-hcch-w73c-jp4m.

Is CVE-2026-32612 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free