CVE-2026-32613 Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling
Attackers can execute arbitrary code on Spinnaker Echo services via unrestricted Spring Expression Language parsing, requiring immediate patching.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32613?
CVE-2026-32613 is a critical code injection vulnerability in spinnaker, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Spinnaker is an open source, multi-cloud continuous delivery platform. Echo like some other services, uses SPeL (Spring Expression Language) to process information - specifically around expected artifacts. In versions prior to 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2, unlike orca, it was NOT restricting that context to a set of trusted classes, but allowing FULL JVM access. This enabled a user to use arbitrary java classes which allow deep access to the system. This enabled the ability to invoke commands, access files, etc. Versions 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2 contain a patch. As a workaround, disable echo entirely.
Weakness: CWE-94
Which versions are affected by CVE-2026-32613?
6 open source packages ship an affected version, including io.spinnaker.echo:echo-pipelinetriggers. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.spinnaker.echo:echo-pipelinetriggers Maven | All versions | 2025.3.2 |
io.spinnaker.echo:echo-pipelinetriggers Maven | All versions | 2025.3.2 |
io.spinnaker.echo:echo-pipelinetriggers Maven | From 2025.4-0 | 2025.4.2 |
io.spinnaker.echo:echo-pipelinetriggers Maven | From 2025.4-0 | 2025.4.2 |
io.spinnaker.echo:echo-pipelinetriggers Maven | From 2026.0-0 | 2026.0.1 |
io.spinnaker.echo:echo-pipelinetriggers Maven | From 2026.0-0 | 2026.0.1 |
Products include Linuxfoundation Spinnaker.
How do I fix CVE-2026-32613?
Upgrade io.spinnaker.echo:echo-pipelinetriggers to a fixed version for your release line: 2025.3.2, 2025.4.2 or 2026.0.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-32613 being exploited?
There is no known exploitation of CVE-2026-32613 in the wild and no public exploit code.
Other vulnerabilities in spinnaker
- CVE-2026-32604 Spinnaker: RCE when using gitrepo artifact types due to improper sanitization of user input on branch and paths
- CVE-2021-43832 Improper Access Control in spinnaker
- CVE-2026-44795 Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types
- CVE-2020-9301 Code injection in Netflix Spinnaker
- CVE-2025-61916 Spinnaker vulnerable to SSRF due to improper restrictions on http from user input
Sources
Also known as GHSA-69rw-45wj-g4v6.