# CVE-2026-32613: Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling

> Attackers can execute arbitrary code on Spinnaker Echo services via unrestricted Spring Expression Language parsing, requiring immediate patching.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-69rw-45wj-g4v6

## What is CVE-2026-32613?

CVE-2026-32613 is a critical code injection vulnerability in spinnaker, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spinnaker is an open source, multi-cloud continuous delivery platform. Echo like some other services, uses SPeL (Spring Expression Language) to process information - specifically around expected artifacts. In versions prior to 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2, unlike orca, it was NOT restricting that context to a set of trusted classes, but allowing FULL JVM access. This enabled a user to use arbitrary java classes which allow deep access to the system. This enabled the ability to invoke commands, access files, etc. Versions 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2 contain a patch. As a workaround, disable echo entirely.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-32613?

6 open source packages ship an affected version, including io.spinnaker.echo:echo-pipelinetriggers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.spinnaker.echo:echo-pipelinetriggers` | Maven | All versions | 2025.3.2 |
| `io.spinnaker.echo:echo-pipelinetriggers` | Maven | All versions | 2025.3.2 |
| `io.spinnaker.echo:echo-pipelinetriggers` | Maven | From 2025.4-0 | 2025.4.2 |
| `io.spinnaker.echo:echo-pipelinetriggers` | Maven | From 2025.4-0 | 2025.4.2 |
| `io.spinnaker.echo:echo-pipelinetriggers` | Maven | From 2026.0-0 | 2026.0.1 |
| `io.spinnaker.echo:echo-pipelinetriggers` | Maven | From 2026.0-0 | 2026.0.1 |

Products: Linuxfoundation Spinnaker.

## How do I fix CVE-2026-32613?

Upgrade io.spinnaker.echo:echo-pipelinetriggers to a fixed version for your release line: 2025.3.2, 2025.4.2 or 2026.0.1.

## Is CVE-2026-32613 being exploited?

There is no known exploitation of CVE-2026-32613 in the wild and no public exploit code.

## Other vulnerabilities in spinnaker

- [CVE-2026-32604](https://insights.sbomify.com/CVE-2026-32604/): Spinnaker: RCE when using gitrepo artifact types due to improper sanitization of user input on branch and paths (critical 10.0)
- [CVE-2021-43832](https://insights.sbomify.com/CVE-2021-43832/): Improper Access Control in spinnaker (critical 10.0)
- [CVE-2026-44795](https://insights.sbomify.com/CVE-2026-44795/): Spinnaker: Non-safe yaml deserialization allowing RCE when using specific types (high 8.8)
- [CVE-2020-9301](https://insights.sbomify.com/CVE-2020-9301/): Code injection in Netflix Spinnaker (high 8.8)
- [CVE-2025-61916](https://insights.sbomify.com/CVE-2025-61916/): Spinnaker vulnerable to SSRF due to improper restrictions on http from user input (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32613 and fix it if it is affected.

What it is: CVE-2026-32613 is a critical code injection vulnerability in spinnaker, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32613 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.spinnaker.echo:echo-pipelinetriggers (Maven): affected all versions; fixed in 2025.3.2
- io.spinnaker.echo:echo-pipelinetriggers (Maven): affected all versions; fixed in 2025.3.2
- io.spinnaker.echo:echo-pipelinetriggers (Maven): affected from 2025.4-0; fixed in 2025.4.2
- io.spinnaker.echo:echo-pipelinetriggers (Maven): affected from 2025.4-0; fixed in 2025.4.2
- io.spinnaker.echo:echo-pipelinetriggers (Maven): affected from 2026.0-0; fixed in 2026.0.1
- io.spinnaker.echo:echo-pipelinetriggers (Maven): affected from 2026.0-0; fixed in 2026.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32613/ (Markdown: https://insights.sbomify.com/CVE-2026-32613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32613
- OSV: https://osv.dev/vulnerability/CVE-2026-32613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32613/
Summaries are generated and may contain mistakes; the official description above is the record.
