{"answers":{"affected":"3 open source packages ship an affected version, including github.com/emmansun/gmsm.","exploited":"There is no known exploitation of CVE-2026-32614 in the wild and no public exploit code.","fix":"Upgrade github.com/emmansun/gmsm to 0.41.1 or later.","what":"CVE-2026-32614 is a high-severity vulnerability in emmansun gmsm, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32614 and fix it if it is affected.\n\nWhat it is: CVE-2026-32614 is a high-severity vulnerability in emmansun gmsm, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-32614 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/emmansun/gmsm (Go): affected all versions; fixed in 0.41.1\n- github.com/emmansun/gmsm (Go): affected all versions; fixed in 0.41.1\n- github.com/emmansun/gmsm (Go): affected all versions; fixed in 0.41.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32614/ (Markdown: https://insights.sbomify.com/CVE-2026-32614/index.md)","id":"CVE-2026-32614","markdown":"https://insights.sbomify.com/CVE-2026-32614/index.md","name":"CVE-2026-32614","record":{"aliases":["GHSA-5xxp-2vrj-x855","GO-2026-4694"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Go cryptographic library","requires_auth":"none","summary":"Attackers can forge valid SM9 ciphertexts and derive decryption keys by exploiting an infinity-point validation flaw in the Go ShangMi library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"Go ShangMi (Commercial Cryptography) Library (GMSM) is a cryptographic library that covers the Chinese commercial cryptographic public algorithms SM2/SM3/SM4/SM9/ZUC. Prior to 0.41.1, the current SM9 decryption implementation contains an infinity-point ciphertext forgery vulnerability. The root cause is that, during decryption, the elliptic-curve point C1 in the ciphertext is only deserialized and checked to be on the curve, but the implementation does not explicitly reject the point at infinity. In the current implementation, an attacker can construct C1 as the point at infinity, causing the bilinear pairing result to degenerate into the identity element in the GT group. As a result, a critical part of the key derivation input becomes a predictable constant. An attacker who only knows the target user's UID can derive the decryption key material and then forge a ciphertext that passes the integrity check. This vulnerability is fixed in 0.41.1.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Go ShangMi SM9 Infinity-Point Ciphertext Forgery Vulnerability","id":"CVE-2026-32614","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"other","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Discourse: Category group moderators can perform actions on topics in restricted categories without read access","id":"CVE-2026-32615"},"packages":[{"ecosystem":"Go","fixed":["0.41.1"],"introduced":["0"],"last_affected":[],"package":"github.com/emmansun/gmsm","purl":null,"source":"GHSA-5xxp-2vrj-x855"},{"ecosystem":"Go","fixed":["0.41.1"],"introduced":["0"],"last_affected":[],"package":"github.com/emmansun/gmsm","purl":"pkg:golang/github.com/emmansun/gmsm","source":"GHSA-5xxp-2vrj-x855"},{"ecosystem":"Go","fixed":["0.41.1"],"introduced":["0"],"last_affected":[],"package":"github.com/emmansun/gmsm","purl":"pkg:golang/github.com/emmansun/gmsm","source":"GO-2026-4694"}],"prev":{"headline":"Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling","id":"CVE-2026-32613"},"products":["gmsm"],"published":"2026-03-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-16","vendors":["emmansun"]},"summary":"Attackers can forge valid SM9 ciphertexts and derive decryption keys by exploiting an infinity-point validation flaw in the Go ShangMi library.","url":"https://insights.sbomify.com/CVE-2026-32614/"}