# CVE-2026-32614: Go ShangMi SM9 Infinity-Point Ciphertext Forgery Vulnerability

> Attackers can forge valid SM9 ciphertexts and derive decryption keys by exploiting an infinity-point validation flaw in the Go ShangMi library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** GHSA-5xxp-2vrj-x855, GO-2026-4694

## What is CVE-2026-32614?

CVE-2026-32614 is a high-severity vulnerability in emmansun gmsm, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Go ShangMi (Commercial Cryptography) Library (GMSM) is a cryptographic library that covers the Chinese commercial cryptographic public algorithms SM2/SM3/SM4/SM9/ZUC. Prior to 0.41.1, the current SM9 decryption implementation contains an infinity-point ciphertext forgery vulnerability. The root cause is that, during decryption, the elliptic-curve point C1 in the ciphertext is only deserialized and checked to be on the curve, but the implementation does not explicitly reject the point at infinity. In the current implementation, an attacker can construct C1 as the point at infinity, causing the bilinear pairing result to degenerate into the identity element in the GT group. As a result, a critical part of the key derivation input becomes a predictable constant. An attacker who only knows the target user's UID can derive the decryption key material and then forge a ciphertext that passes the integrity check. This vulnerability is fixed in 0.41.1.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-32614?

3 open source packages ship an affected version, including github.com/emmansun/gmsm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/emmansun/gmsm` | Go | All versions | 0.41.1 |
| `github.com/emmansun/gmsm` | Go | All versions | 0.41.1 |
| `github.com/emmansun/gmsm` | Go | All versions | 0.41.1 |

## How do I fix CVE-2026-32614?

Upgrade github.com/emmansun/gmsm to 0.41.1 or later.

## Is CVE-2026-32614 being exploited?

There is no known exploitation of CVE-2026-32614 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32614 and fix it if it is affected.

What it is: CVE-2026-32614 is a high-severity vulnerability in emmansun gmsm, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32614 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/emmansun/gmsm (Go): affected all versions; fixed in 0.41.1
- github.com/emmansun/gmsm (Go): affected all versions; fixed in 0.41.1
- github.com/emmansun/gmsm (Go): affected all versions; fixed in 0.41.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32614/ (Markdown: https://insights.sbomify.com/CVE-2026-32614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32614
- OSV: https://osv.dev/vulnerability/CVE-2026-32614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32614/
Summaries are generated and may contain mistakes; the official description above is the record.
