CVE-2026-32619 Discourse: Insufficient topic visibility check allows unauthorized poll manipulation in private categories
Users removed from private categories can still modify poll states in inaccessible topics due to insufficient visibility checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32619?
CVE-2026-32619 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, users who lost access to a topic (e.g., removed from a private category group) could still interact with polls in that topic, including voting and toggling poll status. No content was exposed, but users could modify poll state in topics they should no longer have access to. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Weakness: CWE-285
Which versions are affected by CVE-2026-32619?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | From 2026.1.0 | 2026.1.3, 2026.2.2 |
Products include Discourse Discourse.
How do I fix CVE-2026-32619?
Upgrade discourse to a fixed version for your release line: 2026.1.3 or 2026.2.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-32619 being exploited?
There is no known exploitation of CVE-2026-32619 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-32619, GHSA-wq58-pvf6-w4p8.