CVE-2026-32620 Discourse: Missing post-level authorization allows whisper metadata disclosure

Medium 5.3 Published Updated

Non-staff users can access read receipt metadata for staff-only posts, exposing private user activity information.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-32620?

CVE-2026-32620 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, non-staff users could access read receipt information for staff-only posts they weren't supposed to see. No post content was exposed, only metadata about who read the post and when. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Weakness: CWE-200

Which versions are affected by CVE-2026-32620?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.3, 2026.2.2

Products include Discourse Discourse.

How do I fix CVE-2026-32620?

Upgrade discourse to a fixed version for your release line: 2026.1.3 or 2026.2.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-32620 being exploited?

There is no known exploitation of CVE-2026-32620 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-32620, GHSA-xgg2-vwr6-2c65.

Is CVE-2026-32620 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free