# CVE-2026-32629: phpMyFAQ: Stored XSS via Unsanitized Email Field in Admin FAQ Editor

> An attacker can inject malicious scripts via the email field in guest FAQs, leading to stored XSS in the admin interface.

- **Severity:** Medium 5.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 2 Apr 2026
- **Also known as:** GHSA-98gw-w575-h2ph

## What is CVE-2026-32629?

CVE-2026-32629 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

phpMyFAQ is an open source FAQ web application. Prior to version 4.1.1, an unauthenticated attacker can submit a guest FAQ with an email address that is syntactically valid per RFC 5321 (quoted local part) yet contains raw HTML — for example "<script>alert(1)</script>"@evil.com. PHP's FILTER_VALIDATE_EMAIL accepts this email as valid. The email is stored in the database without HTML sanitization and later rendered in the admin FAQ editor template using Twig's |raw filter, which bypasses auto-escaping entirely. This issue has been patched in version 4.1.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-32629?

4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.1 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.1 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.1 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.1 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2026-32629?

Upgrade phpmyfaq/phpmyfaq to 4.1.1 or later.

## Is CVE-2026-32629 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32629 exists.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32629 and fix it if it is affected.

What it is: CVE-2026-32629 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32629 exists.

Affected packages and fixed versions:
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.1
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.1
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.1
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32629/ (Markdown: https://insights.sbomify.com/CVE-2026-32629/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32629
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32629
- OSV: https://osv.dev/vulnerability/CVE-2026-32629

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32629/
Summaries are generated and may contain mistakes; the official description above is the record.
