{"answers":{"affected":"2 open source packages ship an affected version, including file-type. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32630 exists.","fix":"Upgrade file-type to 21.3.2 or later.","what":"CVE-2026-32630 is a medium-severity denial of service vulnerability in sindresorhus file-type, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32630 and fix it if it is affected.\n\nWhat it is: CVE-2026-32630 is a medium-severity denial of service vulnerability in sindresorhus file-type, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32630 exists.\n\nAffected packages and fixed versions:\n- file-type (npm): affected from 20.0.0; fixed in 21.3.2\n- file-type (npm): affected from 20.0.0; fixed in 21.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32630/ (Markdown: https://insights.sbomify.com/CVE-2026-32630/index.md)","id":"CVE-2026-32630","markdown":"https://insights.sbomify.com/CVE-2026-32630/index.md","name":"CVE-2026-32630","record":{"aliases":["GHSA-j47w-4g3g-c36v","MINI-5fgc-hh74-w3j7","MINI-8ffp-6hfp-hp4x","MINI-cx7f-gw4m-8fr7","MINI-jp73-mxc3-vfmf","ROOT-APP-NPM-CVE-2026-32630"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript file type library","requires_auth":"none","summary":"Attackers can cause denial of service via excessive memory consumption when the library processes crafted ZIP files using buffer or blob detection methods.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"file-type","vendor":"sindresorhus"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"file-type detects the file type of a file, stream, or data. From 20.0.0 to 21.3.1, a crafted ZIP file can trigger excessive memory growth during type detection in file-type when using fileTypeFromBuffer(), fileTypeFromBlob(), or fileTypeFromFile(). The ZIP inflate output limit is enforced for stream-based detection, but not for known-size inputs. As a result, a small compressed ZIP can cause file-type to inflate and process a much larger payload while probing ZIP-based formats such as OOXML. This vulnerability is fixed in 21.3.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"file-type affected by ZIP Decompression Bomb DoS via [Content_Types].xml entry","id":"CVE-2026-32630","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Git for Windows: `git clone` from manipulated repositories can leak NTLM hashes to arbitrary servers","id":"CVE-2026-32631"},"packages":[{"ecosystem":"npm","fixed":["21.3.2"],"introduced":["20.0.0"],"last_affected":[],"package":"file-type","purl":null,"source":"GHSA-j47w-4g3g-c36v"},{"ecosystem":"npm","fixed":["21.3.2"],"introduced":["20.0.0"],"last_affected":[],"package":"file-type","purl":"pkg:npm/file-type","source":"GHSA-j47w-4g3g-c36v"}],"prev":{"headline":"phpMyFAQ: Stored XSS via Unsanitized Email Field in Admin FAQ Editor","id":"CVE-2026-32629"},"products":["file-type"],"published":"2026-03-13","related":[{"cvss_score":5.5,"headline":"file-type vulnerable to Infinite Loop via malformed MKV file","id":"CVE-2022-36313","kev_date_added":null,"published":"2022-07-21"},{"cvss_score":5.3,"headline":"file-type affected by infinite loop in ASF parser on malformed input with zero-size sub-header","id":"CVE-2026-31808","kev_date_added":null,"published":"2026-03-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-16","vendors":["sindresorhus"]},"summary":"Attackers can cause denial of service via excessive memory consumption when the library processes crafted ZIP files using buffer or blob detection methods.","url":"https://insights.sbomify.com/CVE-2026-32630/"}