# CVE-2026-32634: Glances Central Browser Autodiscovery Leaks Reusable Credentials to Zeroconf-Spoofed Servers

> An attacker on the local network can spoof Zeroconf services to steal reusable authentication credentials from Glances Central Browser mode.

- **Severity:** High 8.1 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-32634, GHSA-vx5f-957p-qpvm, PYSEC-2026-2172, UBUNTU-CVE-2026-32634

## What is CVE-2026-32634?

CVE-2026-32634 is a high-severity vulnerability in nicolargo glances, published on 18 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.2, in Central Browser mode, Glances stores both the Zeroconf-advertised server name and the discovered IP address for dynamic servers, but later builds connection URIs from the untrusted advertised name instead of the discovered IP. When a dynamic server reports itself as protected, Glances also uses that same untrusted name as the lookup key for saved passwords and the global `[passwords] default` credential. An attacker on the same local network can advertise a fake Glances service over Zeroconf and cause the browser to automatically send a reusable Glances authentication secret to an attacker-controlled host. This affects the background polling path and the REST/WebUI click-through path in Central Browser mode. Version 4.5.2 fixes the issue.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-32634?

3 open source packages ship an affected version, including glances and Glances. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.2 |
| `glances` | PyPI | All versions | 4.5.2 |
| `Glances` | PyPI | All versions | 4.5.2 |

Products: Nicolargo Glances.

## How do I fix CVE-2026-32634?

Upgrade glances to 4.5.2 or later.

## Is CVE-2026-32634 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32634 exists.

## Other vulnerabilities in nicolargo glances

- [CVE-2026-32633](https://insights.sbomify.com/CVE-2026-32633/): Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist` (critical 9.1)
- [CVE-2026-32596](https://insights.sbomify.com/CVE-2026-32596/): Glances exposes the REST API without authentication (high 8.7)
- [CVE-2026-30928](https://insights.sbomify.com/CVE-2026-30928/): Glances Exposes Unauthenticated Configuration Secrets (high 8.7)
- [CVE-2026-32610](https://insights.sbomify.com/CVE-2026-32610/): Glances's Default CORS Configuration Allows Cross-Origin Credential Theft (high 8.1)
- [CVE-2026-33641](https://insights.sbomify.com/CVE-2026-33641/): Glances Vulnerable to Command Injection via Dynamic Configuration Values (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32634 and fix it if it is affected.

What it is: CVE-2026-32634 is a high-severity vulnerability in nicolargo glances, published on 18 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32634 exists.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.2
- glances (PyPI): affected all versions; fixed in 4.5.2
- Glances (PyPI): affected all versions; fixed in 4.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32634/ (Markdown: https://insights.sbomify.com/CVE-2026-32634/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32634
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32634
- OSV: https://osv.dev/vulnerability/CVE-2026-32634

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32634/
Summaries are generated and may contain mistakes; the official description above is the record.
