# CVE-2026-32635: Angular has XSS in i18n attribute bindings

> Attackers can inject malicious scripts via i18n attribute bindings in Angular applications, bypassing sanitization mechanisms.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2026
- **Updated:** 17 Mar 2026
- **Also known as:** CLSA-2026-1775521847, CLSA-2026-1775521853, CLSA-2026-1792161115, CLSA-2026-1792161116, CLSA-2026-1792163504, CLSA-2026-1792163505, CLSA-2026-1792208088, CLSA-2026-1792208571, CLSA-2026-1792250477, CLSA-2026-1792250594, CLSA-2026-1792281043, CLSA-2026-1792281709, CLSA-2026-1792325307, CLSA-2026-1792326025, CLSA-2026-1792345167, CLSA-2026-1792345722, CLSA-2026-1792357216, CLSA-2026-1792357217, CLSA-2026-1792366530, CLSA-2026-1792366897, CLSA-2026-1792371588, CLSA-2026-1792372069, CLSA-2026-1792376142, CLSA-2026-1792376143, CLSA-2026-1792379945, CLSA-2026-1792380386, CLSA-2026-1792382994, CLSA-2026-1792383054, CLSA-2026-1792386456, CLSA-2026-1792386484, DEBIAN-CVE-2026-32635, GHSA-g93w-mfhg-p222, UBUNTU-CVE-2026-32635

## What is CVE-2026-32635?

CVE-2026-32635 is a high-severity cross-site scripting vulnerability in @angular compiler, published on 13 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20, a Cross-Site Scripting (XSS) vulnerability has been identified in the Angular runtime and compiler. It occurs when the application uses a security-sensitive attribute (for example href on an anchor tag) together with Angular's ability to internationalize attributes. Enabling internationalization for the sensitive attribute by adding i18n-<attribute> name bypasses Angular's built-in sanitization mechanism, which when combined with a data binding to untrusted user-generated data can allow an attacker to inject a malicious script. This vulnerability is fixed in 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-32635?

20 open source packages ship an affected version, including @angular/compiler and @angular/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/compiler` | npm | From 17.0.0-next.0 to 18.2.14 | None |
| `@angular/compiler` | npm | From 17.0.0-next.0 to 18.2.14 | None |
| `@angular/compiler` | npm | From 19.0.0-next.0 | 19.2.20 |
| `@angular/compiler` | npm | From 19.0.0-next.0 | 19.2.20 |
| `@angular/compiler` | npm | From 20.0.0-next.0.0.0 | 20.3.18 |
| `@angular/compiler` | npm | From 20.0.0-next.0.0.0 | 20.3.18 |
| `@angular/compiler` | npm | From 21.0.0-next.0 | 21.2.4 |
| `@angular/compiler` | npm | From 21.0.0-next.0 | 21.2.4 |
| `@angular/compiler` | npm | From 22.0.0-next.0 | 22.0.0-next.3 |
| `@angular/compiler` | npm | From 22.0.0-next.0 | 22.0.0-next.3 |
| `@angular/core` | npm | From 17.0.0-next.0 to 18.2.14 | None |
| `@angular/core` | npm | From 17.0.0-next.0 to 18.2.14 | None |
| `@angular/core` | npm | From 19.0.0-next.0 | 19.2.20 |
| `@angular/core` | npm | From 19.0.0-next.0 | 19.2.20 |
| `@angular/core` | npm | From 20.0.0-next.0.0.0 | 20.3.18 |
| `@angular/core` | npm | From 20.0.0-next.0.0.0 | 20.3.18 |
| `@angular/core` | npm | From 21.0.0-next.0 | 21.2.4 |
| `@angular/core` | npm | From 21.0.0-next.0 | 21.2.4 |
| `@angular/core` | npm | From 22.0.0-next.0 | 22.0.0-next.3 |
| `@angular/core` | npm | From 22.0.0-next.0 | 22.0.0-next.3 |

Products: Angular Angular Cli.

## How do I fix CVE-2026-32635?

Upgrade @angular/compiler to a fixed version for your release line: 19.2.20, 20.3.18, 21.2.4 or 22.0.0-next.3.

## Is CVE-2026-32635 being exploited?

There is no known exploitation of CVE-2026-32635 in the wild and no public exploit code.

Public exploit code:

- Demostracion educativa de mitigacion y deteccion de CVE-2026-32635: XSS en atributos i18n de Angular. (github_poc): https://github.com/fevar54/CVE-2026-32635-Angular-XSS-Mitigation-

## Other vulnerabilities in @angular compiler

- [CVE-2026-44437](https://insights.sbomify.com/CVE-2026-44437/): Angular SSR: Open Redirect and Request Steering via Encoded X-Forwarded-Prefix (medium 6.9)
- [CVE-2026-33397](https://insights.sbomify.com/CVE-2026-33397/): Angular SSR Vulnerable to Protocol-Relative URL Injection via Single Backslash Bypass (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32635 and fix it if it is affected.

What it is: CVE-2026-32635 is a high-severity cross-site scripting vulnerability in @angular compiler, published on 13 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-32635 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/compiler (npm): affected from 17.0.0-next.0 up to 18.2.14; no fix listed
- @angular/compiler (npm): affected from 17.0.0-next.0 up to 18.2.14; no fix listed
- @angular/compiler (npm): affected from 19.0.0-next.0; fixed in 19.2.20
- @angular/compiler (npm): affected from 19.0.0-next.0; fixed in 19.2.20
- @angular/compiler (npm): affected from 20.0.0-next.0.0.0; fixed in 20.3.18
- @angular/compiler (npm): affected from 20.0.0-next.0.0.0; fixed in 20.3.18
- @angular/compiler (npm): affected from 21.0.0-next.0; fixed in 21.2.4
- @angular/compiler (npm): affected from 21.0.0-next.0; fixed in 21.2.4
- @angular/compiler (npm): affected from 22.0.0-next.0; fixed in 22.0.0-next.3
- @angular/compiler (npm): affected from 22.0.0-next.0; fixed in 22.0.0-next.3
- @angular/core (npm): affected from 17.0.0-next.0 up to 18.2.14; no fix listed
- @angular/core (npm): affected from 17.0.0-next.0 up to 18.2.14; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32635/ (Markdown: https://insights.sbomify.com/CVE-2026-32635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32635
- OSV: https://osv.dev/vulnerability/CVE-2026-32635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32635/
Summaries are generated and may contain mistakes; the official description above is the record.
