{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-32641 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-32641 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-32641 is a high-severity denial of service vulnerability in parseablehq parseable, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32641 and fix it if it is affected.\n\nWhat it is: CVE-2026-32641 is a high-severity denial of service vulnerability in parseablehq parseable, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-32641 in the wild and no public exploit code.\n\nAffected product: parseablehq parseable. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32641/ (Markdown: https://insights.sbomify.com/CVE-2026-32641/index.md)","id":"CVE-2026-32641","markdown":"https://insights.sbomify.com/CVE-2026-32641/index.md","name":"CVE-2026-32641","record":{"aliases":["GHSA-x4q9-j9qh-3rpx"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"log analytics platform","requires_auth":"none","summary":"Unauthenticated attackers can cause denial of service in Parseable by sending malformed headers that trigger a panic.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-703","name":"Improper Check or Handling of Exceptional Conditions"},{"id":"CWE-248","name":"Uncaught Exception"}],"description":"Parseable is a log analytics platform built for high-volume data ingestion and analysis. Prior to 3.0.0, src/handlers/http/middleware.rs uses unwrap() while parsing the x-amz-firehose-common-attributes header before authentication. A remote unauthenticated attacker can supply non-UTF-8 header data, malformed JSON, or invalid derived header values that trigger a Rust panic and interrupt request handling, allowing repeated requests to deny service or cause container restart loops. This issue is fixed in version 3.0.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Parseable: Unauthenticated Denial of Service via panic in Kinesis header parsing middleware","id":"CVE-2026-32641","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Apache Artemis: Unauthorized Temporary Address Creation via OpenWire Protocol","id":"CVE-2026-32642"},"packages":[],"prev":{"headline":"(SimpleEval) Objects (including modules) can leak dangerous modules through to direct access inside the sandbox.","id":"CVE-2026-32640"},"products":["parseable"],"published":"2026-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-21","vendors":["parseablehq"]},"summary":"Unauthenticated attackers can cause denial of service in Parseable by sending malformed headers that trigger a panic.","url":"https://insights.sbomify.com/CVE-2026-32641/"}