# CVE-2026-32641: Parseable: Unauthenticated Denial of Service via panic in Kinesis header parsing middleware

> Unauthenticated attackers can cause denial of service in Parseable by sending malformed headers that trigger a panic.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-x4q9-j9qh-3rpx

## What is CVE-2026-32641?

CVE-2026-32641 is a high-severity denial of service vulnerability in parseablehq parseable, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parseable is a log analytics platform built for high-volume data ingestion and analysis. Prior to 3.0.0, src/handlers/http/middleware.rs uses unwrap() while parsing the x-amz-firehose-common-attributes header before authentication. A remote unauthenticated attacker can supply non-UTF-8 header data, malformed JSON, or invalid derived header values that trigger a Rust panic and interrupt request handling, allowing repeated requests to deny service or cause container restart loops. This issue is fixed in version 3.0.0.

Weakness: CWE-703 (Improper Check or Handling of Exceptional Conditions), CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-32641?


## How do I fix CVE-2026-32641?

No fix has been published for CVE-2026-32641 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-32641 being exploited?

There is no known exploitation of CVE-2026-32641 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32641 and fix it if it is affected.

What it is: CVE-2026-32641 is a high-severity denial of service vulnerability in parseablehq parseable, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32641 in the wild and no public exploit code.

Affected product: parseablehq parseable. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32641/ (Markdown: https://insights.sbomify.com/CVE-2026-32641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32641
- OSV: https://osv.dev/vulnerability/CVE-2026-32641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32641/
Summaries are generated and may contain mistakes; the official description above is the record.
