{"answers":{"affected":"1 open source package ship an affected version, including nginx-gateway-fabric. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-32682 in the wild and no public exploit code.","fix":"Upgrade nginx-gateway-fabric to 2.6.4 or later.","what":"CVE-2026-32682 is a high-severity denial of service vulnerability in F5 NGINX Gateway Fabric, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-32682 and fix it if it is affected.\n\nWhat it is: CVE-2026-32682 is a high-severity denial of service vulnerability in F5 NGINX Gateway Fabric, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-32682 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx-gateway-fabric (Bitnami): affected from 1.3.0; fixed in 2.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-32682/ (Markdown: https://insights.sbomify.com/CVE-2026-32682/index.md)","id":"CVE-2026-32682","markdown":"https://insights.sbomify.com/CVE-2026-32682/index.md","name":"CVE-2026-32682","record":{"aliases":["BIT-nginx-gateway-fabric-2026-32682","GHSA-vh3x-jr27-wpwh"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX Gateway Fabric","requires_auth":"low_privilege","summary":"An authenticated attacker with GRPCRoute permissions can crash the NGINX Gateway Fabric control plane by sending malicious backendRef filters.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_gateway_fabric","vendor":"f5"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-129","name":"Improper Validation of Array Index"}],"description":"When NGINX Gateway Fabric is configured using GRPCRoutes, an authenticated, remote attacker with permission to create or modify GRPCRoute resources can cause the NGINX Gateway Fabric control plane to terminate by sending undisclosed GRPCRoute configurations containing backendRef filters. \n\nNote: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-32682","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Information disclosure in EZVIZ APP","id":"CVE-2026-32683"},"packages":[{"ecosystem":"Bitnami","fixed":["2.6.4"],"introduced":["1.3.0"],"last_affected":[],"package":"nginx-gateway-fabric","purl":"pkg:bitnami/nginx-gateway-fabric","source":"BIT-nginx-gateway-fabric-2026-32682"}],"prev":{"headline":"Privilege escalation in RATOC RAID Monitoring Manager for Windows","id":"CVE-2026-32680"},"products":["NGINX Gateway Fabric"],"published":"2026-06-17","related":[{"cvss_score":9.2,"headline":"NGINX Map directive and Regex matching vulnerability","id":"CVE-2026-42533","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":9.2,"headline":"NGINX Open-Source ngx_http_v3_module vulnerability","id":"CVE-2026-42530","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.8,"headline":"NGINX ngx_http_slice_module vulnerability","id":"CVE-2026-60005","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.6,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-11311","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.6,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-50107","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.3,"headline":"NGINX ngx_http_ssi_module vulnerability","id":"CVE-2026-56434","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.2,"headline":"NGINX vulnerability","id":"CVE-2026-1642","kev_date_added":null,"published":"2026-02-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-18","vendors":["F5"]},"summary":"An authenticated attacker with GRPCRoute permissions can crash the NGINX Gateway Fabric control plane by sending malicious backendRef filters.","url":"https://insights.sbomify.com/CVE-2026-32682/"}