# CVE-2026-32682: NGINX Gateway Fabric vulnerability

> An authenticated attacker with GRPCRoute permissions can crash the NGINX Gateway Fabric control plane by sending malicious backendRef filters.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** BIT-nginx-gateway-fabric-2026-32682, GHSA-vh3x-jr27-wpwh

## What is CVE-2026-32682?

CVE-2026-32682 is a high-severity denial of service vulnerability in F5 NGINX Gateway Fabric, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When NGINX Gateway Fabric is configured using GRPCRoutes, an authenticated, remote attacker with permission to create or modify GRPCRoute resources can cause the NGINX Gateway Fabric control plane to terminate by sending undisclosed GRPCRoute configurations containing backendRef filters. 

Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-32682?

1 open source package ship an affected version, including nginx-gateway-fabric. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx-gateway-fabric` | Bitnami | From 1.3.0 | 2.6.4 |

Products: F5 Nginx Gateway Fabric.

## How do I fix CVE-2026-32682?

Upgrade nginx-gateway-fabric to 2.6.4 or later.

## Is CVE-2026-32682 being exploited?

There is no known exploitation of CVE-2026-32682 in the wild and no public exploit code.

## Other vulnerabilities in F5 NGINX Gateway Fabric

- [CVE-2026-42533](https://insights.sbomify.com/CVE-2026-42533/): NGINX Map directive and Regex matching vulnerability (critical 9.2)
- [CVE-2026-42530](https://insights.sbomify.com/CVE-2026-42530/): NGINX Open-Source ngx_http_v3_module vulnerability (critical 9.2)
- [CVE-2026-60005](https://insights.sbomify.com/CVE-2026-60005/): NGINX ngx_http_slice_module vulnerability (high 8.8)
- [CVE-2026-11311](https://insights.sbomify.com/CVE-2026-11311/): NGINX Gateway Fabric vulnerability (high 8.6)
- [CVE-2026-50107](https://insights.sbomify.com/CVE-2026-50107/): NGINX Gateway Fabric vulnerability (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32682 and fix it if it is affected.

What it is: CVE-2026-32682 is a high-severity denial of service vulnerability in F5 NGINX Gateway Fabric, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32682 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx-gateway-fabric (Bitnami): affected from 1.3.0; fixed in 2.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32682/ (Markdown: https://insights.sbomify.com/CVE-2026-32682/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32682
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32682
- OSV: https://osv.dev/vulnerability/CVE-2026-32682

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32682/
Summaries are generated and may contain mistakes; the official description above is the record.
