# CVE-2026-32688: Atom table exhaustion via HTTP/2 :scheme pseudo-header in plug_cowboy

> Unauthenticated attackers can crash the Erlang VM by exhausting the atom table via malicious HTTP/2 scheme headers in plug_cowboy.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 29 Apr 2026
- **Also known as:** EEF-CVE-2026-32688, GHSA-q8x4-x7mp-5vg2

## What is CVE-2026-32688?

CVE-2026-32688 is a high-severity denial of service vulnerability in elixir-plug plug_cowboy, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Allocation of Resources Without Limits or Throttling vulnerability in elixir-plug plug_cowboy allows unauthenticated remote denial of service via atom table exhaustion.

Plug.Cowboy.Conn.conn/1 in lib/plug/cowboy/conn.ex calls String.to_atom/1 on the value returned by :cowboy_req.scheme/1. For HTTP/2 connections, cowlib passes the client-supplied :scheme pseudo-header value through verbatim without validation. Each unique value permanently allocates a new entry in the BEAM atom table. Since atoms are never garbage-collected and the atom table has a fixed limit (default 1,048,576), an unauthenticated attacker can exhaust the table by sending HTTP/2 requests with unique :scheme values, causing the Erlang VM to abort with system_limit and taking down the entire node.

This vulnerability does not affect HTTP/1.1, where cowboy derives the scheme from the listener type rather than from a client-supplied header.

This issue affects plug_cowboy: from 2.0.0 before 2.8.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-32688?

3 open source packages ship an affected version, including plug_cowboy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plug_cowboy` | Hex | From 2.0.0 | 2.8.1 |
| `plug_cowboy` | Hex | From 2.0.0 | 2.8.1 |
| `plug_cowboy` | Hex | From 2.0.0 | 2.8.1 |

Products: Elixir-Plug Plug.cowboy.

## How do I fix CVE-2026-32688?

Upgrade plug_cowboy to 2.8.1 or later.

## Is CVE-2026-32688 being exploited?

There is no known exploitation of CVE-2026-32688 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32688 and fix it if it is affected.

What it is: CVE-2026-32688 is a high-severity denial of service vulnerability in elixir-plug plug_cowboy, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32688 in the wild and no public exploit code.

Affected packages and fixed versions:
- plug_cowboy (Hex): affected from 2.0.0; fixed in 2.8.1
- plug_cowboy (Hex): affected from 2.0.0; fixed in 2.8.1
- plug_cowboy (Hex): affected from 2.0.0; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32688/ (Markdown: https://insights.sbomify.com/CVE-2026-32688/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32688
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32688
- OSV: https://osv.dev/vulnerability/CVE-2026-32688

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32688/
Summaries are generated and may contain mistakes; the official description above is the record.
