CVE-2026-32689 Long-poll NDJSON body splitting causes unbounded memory allocation in Phoenix
An attacker can crash the Phoenix server by sending a large NDJSON body to the long-poll transport, causing unbounded memory allocation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-32689?
CVE-2026-32689 is a high-severity denial of service vulnerability in phoenixframework phoenix, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Allocation of Resources Without Limits or Throttling vulnerability in phoenixframework phoenix allows a denial of service via the long-poll transport's NDJSON body handling.
In 'Elixir.Phoenix.Transports.LongPoll':publish/4, when a POST request is received with Content-Type: application/x-ndjson, the request body is split on newline characters using String.split/2 with no limit on the number of resulting segments. An attacker can send a body consisting entirely of newline bytes, causing a 1:1 amplification into a list of empty binaries — a 1 MB body produces approximately one million list elements, an 8 MB body approximately 8.4 million. Each element is then walked by Enum.map, materializing another list of the same size. This exhausts BEAM memory and schedulers, crashing the node and terminating all active sessions.
A session token required to reach the vulnerable endpoint is freely obtainable by any client via an unauthenticated GET request to the same URL with a matching Origin header, making this attack effectively unauthenticated.
This issue affects phoenix: from 1.7.0 before 1.7.22 and 1.8.6.
Weakness: CWE-770
Which versions are affected by CVE-2026-32689?
5 open source packages ship an affected version, including phoenix.
| Package | Affected | Fixed in |
|---|---|---|
phoenix Hex | From 1.7.0 | 1.7.22, 1.8.6 |
phoenix Hex | From 1.7.0 | 1.7.22 |
phoenix Hex | From 1.7.0 | 1.7.22 |
phoenix Hex | From 1.8.0 | 1.8.6 |
phoenix Hex | From 1.8.0 | 1.8.6 |
How do I fix CVE-2026-32689?
Upgrade phoenix to a fixed version for your release line: 1.7.22 or 1.8.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-32689 being exploited?
There is no known exploitation of CVE-2026-32689 in the wild and no public exploit code.
Sources
Also known as EEF-CVE-2026-32689, GHSA-628h-q48j-jr6q.