# CVE-2026-32690: Apache Airflow: 3.x - Nested Variable Secret Values Bypass Redaction via max_depth=1

> Attackers can view unmasked secrets in nested JSON variables, exposing sensitive data to unauthorized users.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** BIT-airflow-2026-32690, ECHO-896a-a1cc-908a, GHSA-w9r4-94fj-xp69, MINI-2p87-cqfr-674m, PYSEC-2026-19, PYSEC-2026-2362

## What is CVE-2026-32690?

CVE-2026-32690 is a low-severity vulnerability in Apache Airflow, published on 18 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Secrets in Variables saved as JSON dictionaries were not properly redacted - in case thee variables were retrieved by the user the secrets stored as nested fields were not masked.

If you do not store variables with sensitive values in JSON form, you are not affected. Otherwise please upgrade to Apache Airflow 3.2.0 that has the fix implemented

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2026-32690?

7 open source packages ship an affected version, including apache-airflow, airflow and apache-airflow-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `apache-airflow` | PyPI | From 3.0.0 | 3.2.0 |
| `airflow` | Bitnami | From 3.0.0 | 3.2.0 |
| `apache-airflow-core` | PyPI | From 3.0.0 | 3.2.0 |
| `apache-airflow-core` | PyPI | From 3.0.0 | 3.2.0 |
| `apache-airflow-core` | PyPI | From 3.0.0 | 3.2.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-32690?

Upgrade apache-airflow to 3.2.0 or later.

## Is CVE-2026-32690 being exploited?

There is no known exploitation of CVE-2026-32690 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32690 and fix it if it is affected.

What it is: CVE-2026-32690 is a low-severity vulnerability in Apache Airflow, published on 18 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32690 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- apache-airflow (PyPI): affected from 3.0.0; fixed in 3.2.0
- airflow (Bitnami): affected from 3.0.0; fixed in 3.2.0
- apache-airflow-core (PyPI): affected from 3.0.0; fixed in 3.2.0
- apache-airflow-core (PyPI): affected from 3.0.0; fixed in 3.2.0
- apache-airflow-core (PyPI): affected from 3.0.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32690/ (Markdown: https://insights.sbomify.com/CVE-2026-32690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32690
- OSV: https://osv.dev/vulnerability/CVE-2026-32690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32690/
Summaries are generated and may contain mistakes; the official description above is the record.
