# CVE-2026-32701: Qwik has array method pollution in FormData processing, allowing type confusion and DoS

> Attackers can cause denial of service and type confusion in Qwik applications by submitting crafted form data with mixed array and object keys.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-whhv-gg5v-864r

## What is CVE-2026-32701?

CVE-2026-32701 is a high-severity vulnerability in QwikDev qwik, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Qwik is a performance-focused JavaScript framework. Versions prior to 1.19.2 improperly inferred arrays from dotted form field names during FormData parsing. By submitting mixed array-index and object-property keys for the same path, an attacker could cause user-controlled properties to be written onto values that application code expected to be arrays. When processing application/x-www-form-urlencoded or multipart/form-data requests, Qwik City converted dotted field names (e.g., items.0, items.1) into nested structures. If a path was interpreted as an array, additional attacker-supplied keys on that path—such as items.toString, items.push, items.valueOf, or items.length—could alter the resulting server-side value in unexpected ways, potentially leading to request handling failures, denial of service through malformed array state or oversized lengths, and type confusion in downstream code. This issue was fixed in version 1.19.2.

Weakness: CWE-843 (Access of Resource Using Incompatible Type), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-32701?

2 open source packages ship an affected version, including @builder.io/qwik-city. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@builder.io/qwik-city` | npm | All versions | 1.19.2 |
| `@builder.io/qwik-city` | npm | All versions | 1.19.2 |

Products: Qwik Qwik.

## How do I fix CVE-2026-32701?

Upgrade @builder.io/qwik-city to 1.19.2 or later.

## Is CVE-2026-32701 being exploited?

There is no known exploitation of CVE-2026-32701 in the wild and no public exploit code.

## Other vulnerabilities in QwikDev qwik

- [CVE-2023-1283](https://insights.sbomify.com/CVE-2023-1283/): Code Injection in builderio/qwik (critical 10.0)
- [CVE-2026-25150](https://insights.sbomify.com/CVE-2026-25150/): Prototype Pollution via FormData Processing in Qwik City (critical 9.3)
- [CVE-2026-27971](https://insights.sbomify.com/CVE-2026-27971/): Qwik affected by unauthenticated RCE via server$ Deserialization (critical 9.2)
- [CVE-2024-41677](https://insights.sbomify.com/CVE-2024-41677/): Cross-site Scripting (XSS) vulnerability due to improper HTML escaping in qwik (medium 6.3)
- [CVE-2023-0410](https://insights.sbomify.com/CVE-2023-0410/): Cross-site Scripting (XSS) - Generic in builderio/qwik (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32701 and fix it if it is affected.

What it is: CVE-2026-32701 is a high-severity vulnerability in QwikDev qwik, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-32701 in the wild and no public exploit code.

Affected packages and fixed versions:
- @builder.io/qwik-city (npm): affected all versions; fixed in 1.19.2
- @builder.io/qwik-city (npm): affected all versions; fixed in 1.19.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32701/ (Markdown: https://insights.sbomify.com/CVE-2026-32701/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32701
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32701
- OSV: https://osv.dev/vulnerability/CVE-2026-32701

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32701/
Summaries are generated and may contain mistakes; the official description above is the record.
