# CVE-2026-32705: PX4 autopilot BST Device Name Length Can Overflow Driver Buffer

> A malicious BST device can trigger a stack buffer overflow in the PX4 autopilot driver, potentially leading to code execution or system crashes.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Mar 2026
- **Updated:** 17 Mar 2026
- **Also known as:** GHSA-79mp-34pp-2f3f

## What is CVE-2026-32705?

CVE-2026-32705 is a medium-severity memory corruption vulnerability in PX4-Autopilot, published on 13 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, the BST telemetry probe writes a string terminator using a device-provided length without bounds. A malicious BST device can report an oversized dev_name_len, causing a stack overflow in the driver and crashing the task (or enabling code execution). This vulnerability is fixed in 1.17.0-rc2.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-32705?

It affects 1 product.


Products: Dronecode Px4 Drone Autopilot.

## How do I fix CVE-2026-32705?

No fix has been published for CVE-2026-32705 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-32705 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32705 exists.

## Other vulnerabilities in PX4-Autopilot

- [CVE-2026-26741](https://insights.sbomify.com/CVE-2026-26741/): Business logic in n/a (high 8.1)
- [CVE-2026-26742](https://insights.sbomify.com/CVE-2026-26742/): Security feature bypass in n/a (high 8.1)
- [CVE-2024-40427](https://insights.sbomify.com/CVE-2024-40427/): Memory corruption in n/a (high 7.9)
- [CVE-2026-32708](https://insights.sbomify.com/CVE-2026-32708/): Zenoh uORB Subscriber Allows Arbitrary Stack Allocation (PX4/PX4-Autopilot) (high 7.8)
- [CVE-2024-38952](https://insights.sbomify.com/CVE-2024-38952/): Memory corruption in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32705 and fix it if it is affected.

What it is: CVE-2026-32705 is a medium-severity memory corruption vulnerability in PX4-Autopilot, published on 13 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32705 exists.

Affected product: PX4-Autopilot. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32705/ (Markdown: https://insights.sbomify.com/CVE-2026-32705/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32705
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32705
- OSV: https://osv.dev/vulnerability/CVE-2026-32705

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32705/
Summaries are generated and may contain mistakes; the official description above is the record.
