CVE-2026-32711 pydicom: Path traversal in FileSet/DICOMDIR ReferencedFileID allows file access outside the File-set root

High 7.8 Published Updated

Attackers can read, copy, or delete arbitrary files outside the intended directory by crafting malicious DICOMDIR paths in pydicom.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-32711?

CVE-2026-32711 is a high-severity path traversal vulnerability in pydicom, published on 20 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

pydicom is a pure Python package for working with DICOM files. Versions 2.0.0-rc.1 through 3.0.1 are vulnerable to Path Traversal through a maliciously crafted DICOMDIR ReferencedFileID when it is set to a path outside the File-set root. pydicom resolves the path only to confirm that it exists, but does not verify that the resolved path remains under the File-set root. Subsequent public FileSet operations such as copy(), write(), and remove()+write(use_existing=True) use that unchecked path in file I/O operations. This allows arbitrary file read/copy and, in some flows, move/delete outside the File-set root. This issue has been fixed in version 3.0.2.

Weakness: CWE-22

Which versions are affected by CVE-2026-32711?

5 open source packages ship an affected version, including pydicom. It affects 1 product.

PackageAffectedFixed in
pydicom PyPIAll versions2.4.5
pydicom PyPIAll versions2.4.5
pydicom PyPIFrom 2.0.03.0.2
pydicom PyPIFrom 3.0.03.0.2
pydicom PyPIFrom 3.0.03.0.2
Linux distribution packages (1)
python-pydicom openSUSE:TumbleweedAll versions3.0.2-1.1

Products include Pydicom Pydicom.

How do I fix CVE-2026-32711?

Upgrade pydicom to a fixed version for your release line: 2.4.5 or 3.0.2.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-32711 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32711 exists.

Sources

Also known as DEBIAN-CVE-2026-32711, GHSA-v856-2rf8-9f28, PYSEC-2026-2266, UBUNTU-CVE-2026-32711, openSUSE-SU-2026:10412-1.

Is CVE-2026-32711 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free