# CVE-2026-32711: pydicom: Path traversal in FileSet/DICOMDIR ReferencedFileID allows file access outside the File-set root

> Attackers can read, copy, or delete arbitrary files outside the intended directory by crafting malicious DICOMDIR paths in pydicom.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-32711, GHSA-v856-2rf8-9f28, PYSEC-2026-2266, UBUNTU-CVE-2026-32711, openSUSE-SU-2026:10412-1

## What is CVE-2026-32711?

CVE-2026-32711 is a high-severity path traversal vulnerability in pydicom, published on 20 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

pydicom is a pure Python package for working with DICOM files. Versions 2.0.0-rc.1 through 3.0.1 are vulnerable to Path Traversal through a maliciously crafted DICOMDIR ReferencedFileID when it is set to a path outside the File-set root. pydicom resolves the path only to confirm that it exists, but does not verify that the resolved path remains under the File-set root. Subsequent public FileSet operations such as copy(), write(), and remove()+write(use_existing=True) use that unchecked path in file I/O operations. This allows arbitrary file read/copy and, in some flows, move/delete outside the File-set root. This issue has been fixed in version 3.0.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-32711?

5 open source packages ship an affected version, including pydicom. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pydicom` | PyPI | All versions | 2.4.5 |
| `pydicom` | PyPI | All versions | 2.4.5 |
| `pydicom` | PyPI | From 2.0.0 | 3.0.2 |
| `pydicom` | PyPI | From 3.0.0 | 3.0.2 |
| `pydicom` | PyPI | From 3.0.0 | 3.0.2 |
| `python-pydicom` | openSUSE:Tumbleweed | All versions | 3.0.2-1.1 |

Products: Pydicom Pydicom.

## How do I fix CVE-2026-32711?

Upgrade pydicom to a fixed version for your release line: 2.4.5 or 3.0.2.

## Is CVE-2026-32711 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32711 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32711 and fix it if it is affected.

What it is: CVE-2026-32711 is a high-severity path traversal vulnerability in pydicom, published on 20 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32711 exists.

Affected packages and fixed versions:
- pydicom (PyPI): affected all versions; fixed in 2.4.5
- pydicom (PyPI): affected all versions; fixed in 2.4.5
- pydicom (PyPI): affected from 2.0.0; fixed in 3.0.2
- pydicom (PyPI): affected from 3.0.0; fixed in 3.0.2
- pydicom (PyPI): affected from 3.0.0; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32711/ (Markdown: https://insights.sbomify.com/CVE-2026-32711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32711
- OSV: https://osv.dev/vulnerability/CVE-2026-32711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32711/
Summaries are generated and may contain mistakes; the official description above is the record.
