# CVE-2026-32712: Open Source Point of Sale has Stored XSS in Customer Name (Sales)

> An attacker with customer management permissions can inject JavaScript into customer names, executing code in the browsers of users viewing the Daily Sales page.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 7 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-hcfr-9hfv-mcwp

## What is CVE-2026-32712?

CVE-2026-32712 is a medium-severity cross-site scripting vulnerability in opensourcepos, published on 7 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open Source Point of Sale is a web based point-of-sale application written in PHP using CodeIgniter framework. Prior to 3.4.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Daily Sales management table. The customer_name column is configured with escape: false in the bootstrap-table column configuration, causing customer names to be rendered as raw HTML. An attacker with customer management permissions can inject arbitrary JavaScript into a customer's first_name or last_name field, which executes in the browser of any user viewing the Daily Sales page. This vulnerability is fixed in 3.4.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-32712?

It affects 1 product.


Products: Opensourcepos Open Source Point of Sale.

## How do I fix CVE-2026-32712?

No fix has been published for CVE-2026-32712 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-32712 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32712 exists.

## Other vulnerabilities in opensourcepos

- [CVE-2026-32888](https://insights.sbomify.com/CVE-2026-32888/): Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality (high 8.8)
- [CVE-2026-26746](https://insights.sbomify.com/CVE-2026-26746/): Path traversal in n/a (high 8.8)
- [CVE-2025-68434](https://insights.sbomify.com/CVE-2025-68434/): opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation (high 8.8)
- [CVE-2025-68147](https://insights.sbomify.com/CVE-2025-68147/): opensourcepos has a Cross-site Scripting vulnerability (high 8.1)
- [CVE-2025-63800](https://insights.sbomify.com/CVE-2025-63800/): Auth bypass in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32712 and fix it if it is affected.

What it is: CVE-2026-32712 is a medium-severity cross-site scripting vulnerability in opensourcepos, published on 7 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32712 exists.

Affected product: opensourcepos. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32712/ (Markdown: https://insights.sbomify.com/CVE-2026-32712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32712
- OSV: https://osv.dev/vulnerability/CVE-2026-32712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32712/
Summaries are generated and may contain mistakes; the official description above is the record.
