# CVE-2026-32716: SciTokens: Authorization Bypass via Incorrect Scope Path Prefix Checking

> Attackers can bypass authorization checks to access sibling paths due to incorrect prefix matching in the SciTokens library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 31 Mar 2026
- **Also known as:** GHSA-w8fp-g9rh-34jh, PYSEC-2026-2276

## What is CVE-2026-32716?

CVE-2026-32716 is a high-severity authentication bypass vulnerability in scitokens, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SciTokens is a reference library for generating and using SciTokens. Prior to version 1.9.6, the Enforcer incorrectly validates scope paths by using a simple prefix match (startswith). This allows a token with access to a specific path (e.g., /john) to also access sibling paths that start with the same prefix (e.g., /johnathan, /johnny), which is an Authorization Bypass. This issue has been patched in version 1.9.6.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-32716?

3 open source packages ship an affected version, including scitokens. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `scitokens` | PyPI | All versions | 1.9.6 |
| `scitokens` | PyPI | All versions | 1.9.6 |
| `scitokens` | PyPI | All versions | 1.9.6 |

Products: Scitokens Scitokens Library.

## How do I fix CVE-2026-32716?

Upgrade scitokens to 1.9.6 or later.

## Is CVE-2026-32716 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32716 exists.

## Other vulnerabilities in scitokens

- [CVE-2026-32714](https://insights.sbomify.com/CVE-2026-32714/): SciTokens vulnerable to SQL Injection in KeyCache (critical 9.8)
- [CVE-2026-32727](https://insights.sbomify.com/CVE-2026-32727/): SciTokens: Authorization Bypass via Path Traversal in Scope Validation (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-32716 and fix it if it is affected.

What it is: CVE-2026-32716 is a high-severity authentication bypass vulnerability in scitokens, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-32716 exists.

Affected packages and fixed versions:
- scitokens (PyPI): affected all versions; fixed in 1.9.6
- scitokens (PyPI): affected all versions; fixed in 1.9.6
- scitokens (PyPI): affected all versions; fixed in 1.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-32716/ (Markdown: https://insights.sbomify.com/CVE-2026-32716/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-32716
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-32716
- OSV: https://osv.dev/vulnerability/CVE-2026-32716

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-32716/
Summaries are generated and may contain mistakes; the official description above is the record.
